0

I'm trying to proxy HTTP requests from one server to another - both are running HAProxy.

I have the backend defined from the originating server as:

    backend site100
        option redispatch
        option forwardfor 
        server server1 123.123.123.123 maxconn 32

However when doing a request the response is a 502 Bad Gateway and in in the debug logs of the destination server I'm just getting a SSL handshake failure:

Feb 24 10:43:11 XenonKiloCranberry haproxy[5749]: 116.203.70.99:36908 [24/Feb/2020:10:43:11.960] https-in/1: SSL handshake failure

Is this possibly due to the SSL certificate being a SAN / SNI? Perhaps haproxy does not support this? How can I resolve this?

1

Solved it with:

    backend site100
        option redispatch
        option forwardfor 
        option tcplog
        option ssl-hello-chk
        server server1 123.123.123.123 maxconn 32 check ssl verify required ca-file /etc/ssl/certs/ca-certificates.crt

Seems it's due to the ssl verify required ca-file /etc/ssl/certs/ca-certificates.crt options

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.