0

I have a Dell R230. I'm trying to install FreeNAS 11.3 and use an USB stick as boot medium.

I tried three different USB sticks (all of which work for booting on other computers): - Kingston DTSE9 G2 USB 3.0 32GB - SanDisk Ultra Fit USB 3.1 32GB - Samsung Bar Plus USB 3.1 32GB

all are recognized during FreeNas installation and I can install the system onto them (I tried both BIOS boot and UEFI boot with all of them).

After installing and rebooting the system however, it's not possible to boot from the USB Stick. In the system BIOS, independently of whether I set the BOOT option to BIOS or to UEFI, USB does not show up as boot option (the R230 manual however mentions clearly booting from USB, though there are no instructions on how to do it).

I tried both the internal USB 3.0 port as well as the two backside USB 3.0 ports.

I tried BIOS version 2.7.1 and BIOS version 2.8.1

I don't have the iDrac 8 enterprise license, just the standard license.

Do I need to do anything special to be able to boot from USB? (I don't care whether it's MBR based BIOS boot or UEFI boot with GPT partition)

0

You must set BIOS boot priority from within Lifecycle Controller. Once the system boots into the controller, go to:

System setup --> Advanced Hardware Config --> Boot Settings --> UEFI Boot Settings (assuming you're running UEFI and not PXE) --> UEFI Boot Sequence --> [Select USB as 1st device].

You must also make sure that in UEFI mode, the USB stick is formatted as FAT, not NTFS. To boot as UEFI the boot loader must be on a FAT partition.

| improve this answer | |
  • I did that but in UEFI Boot Sequence --> [Select USB as 1st device]. there is no USB option. I tried both BIOS based installations (which creates an MBR usb stick) and UEFI based installation (Which creates a GPT based usb stick with a fat efi partition). The sticks boot on other computers, but on my DELL I don't get to see the USB stick as boot option in the Boot Sequence (neither for UEFI nor for BIOS) – user1282931 Mar 4 at 13:26
  • why are you booting from USB and not the virtual media on the drac controller? - anyway, I think you need to disable secure boot – Sum1sAdmin Mar 4 at 13:33
  • Try letting the stick connected, reboot and use F12 to activate the one-time boot menu. See if it detects it there. Let it be on USB 2 rather than 3.0. – Overmind Mar 4 at 13:46
  • Figured it works when I use the USB ports in the front. But I have to use the internal port or the backports – user1282931 Mar 4 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.