0

I have an RHEL7 on one of the Azure instance and I have installed httpd there. Now I am trying to access the url, which is like myhostname-eastus.cloudapp.azure.com, but it is timedout. I tried to ping to this address, but it is also timing out. However, I am able to SSH to this doamin. I have the port 80 open, but it is not working again reloading the firewall. Following is the output of lsof

lsof -i -P |grep http
httpd    28060     root    4u  IPv6 24469984      0t0  TCP *:80 (LISTEN)
httpd    28061   apache    4u  IPv6 24469984      0t0  TCP *:80 (LISTEN)
httpd    28062   apache    4u  IPv6 24469984      0t0  TCP *:80 (LISTEN)
httpd    28063   apache    4u  IPv6 24469984      0t0  TCP *:80 (LISTEN)
httpd    28064   apache    4u  IPv6 24469984      0t0  TCP *:80 (LISTEN)
httpd    28065   apache    4u  IPv6 24469984      0t0  TCP *:80 (LISTEN)

and netstat is giving the following info :

netstat -tnlp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN      1/systemd
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      2168/sshd
tcp6       0      0 :::111                  :::*                    LISTEN      1/systemd
tcp6       0      0 :::80                   :::*                    LISTEN      28060/httpd
tcp6       0      0 :::22                   :::*                    LISTEN      2168/sshd
0

By default, the configuration of a Linux VM only enables inbound SSH. You’ll need to enable inbound port 80 on the NSG associated with the public IP address (NIC/subnet/etc.)

ICMP isn’t supported at all.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.