3

On Win2008R2 x64 I get

Input Error: There is no script engine for file extension ".vbs".

when starting a .vbs file.

migrated from superuser.com Jan 7 '10 at 20:35

This question came from our site for computer enthusiasts and power users.

1

Here are a couple of possible solutions from this blog:

Open a command prompt and type (make sure you have admin privileges in the console):

regsvr32 %systemroot%\system32\vbscript.dll

Or if that doesn't work.

  1. Locate the file %windir%\inf\wsh.inf (inf is a hidden folder)

  2. right click and select “Install”.

  • regsvr32 doesn't help and in my inf folder there is NO wsh.inf between wsdscdrv.inf and wstorflt.inf, ... on the whole system there is no wsh.inf – user28271 Jan 7 '10 at 20:28
1

You can register a default scripting host:

cscript.exe //H:WScript

You may also want to try adding these registry keys:

http://www.winhelponline.com/articles/105/1/File-association-fixes-for-Windows-Vista.html or http://www.nilpo.com/2009/07/windows-xp/error-there-is-no-script-engine-for-file-extension/

But I believe the .REG files provided are the same

0

try installing WSH 5.6 and let me know how it works.

http://www.microsoft.com/downloads/details.aspx?FamilyID=C717D943-7E4B-4622-86EB-95A22B832CAA&displaylang=en

-1

the HKR\Vbscript registry entry was missing on mine

previous entry worked https://serverfault.com/a/100630/402397

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.