We have a Power Bi file that connects to our MariaDB for data using MySQL ODBC connector. Yesterday we noticed that it can't find one of the required tables in the database, and after some digging we found out, that the table has system versioning enabled. Because none of the other tables had system versioning enabled and all of those tables worked we though that must be the culprit, which turned out to be right as after disabling the feature Power Bi could immediately find the table again.

We tried installing MariaDB/ODBC connector instead of MySQL/ODBC connector in hopes of being able to query a system versioned data table from Power Bi, but that did not solve the problem.

Is it possible to use a system versioned data table in Power Bi either through ODBC, or some other techinque? If it is, how can one do that?

  • SHOW VARIABLES LIKE 'version';
    – Rick James
    Mar 14, 2020 at 19:41
  • MariaDB [(none)]> SHOW VARIABLES LIKE 'version'; +---------------+---------------------+ | Variable_name | Value | +---------------+---------------------+ | version | 10.3.22-MariaDB-log | +---------------+---------------------+
    – nyoatype
    Mar 17, 2020 at 11:31
  • Your question might get more traction on dba.stackexchange.com
    – Rick James
    Mar 25, 2020 at 16:19


You must log in to answer this question.

Browse other questions tagged .