0

I want to configure Netgear router on remote machine its new router connected to Ethernet port of windows 7 laptop and this laptop is also connected to wifi (Internet ) due to which i have remote access to it over team viewer.

so when i visit 192.168.1.1 am not able to access Netgear router login page. Because the requests are going through WLAN which internet access. so i try to route the 192.168.1.1 ip to LAN interface but no success.

here is what i did

  • i assigned ip address to interface
Description: Realtek PCIe GBE Family Controller
DHCP Enabled: No
IPv4 Address: 192.168.1.10
IPv4 Subnet Mask: 255.255.255.0
IPv4 Default Gateway: 192.168.1.1
IPv4 DNS Server: 192.168.1.1
IPv4 WINS Server: 
NetBIOS over Tcpip Enabled: Yes
  • i added to route table

route ADD 192.168.1.1 MASK 255.255.255.255 192.168.1.1 IF 10

here is my route print output which shows its added correctly but still am not able to login to netgear router , any idea what am doing wrong

> C:\Windows\system32>route print
> =========================================================================== Interface List
>  18...00 bb bb 50 90 05 ......Juniper Network Connect Virtual Adapter
>  15...ac 71 90 b4 a7 b2 ......Microsoft Virtual WiFi Miniport Adapter
>  11...bc 8b 20 30 a2 82 ......Broadcom 4313 802.11b/g/n
>  10...cc 71 50 ff d6 dd ......Realtek PCIe GBE Family Controller
>   1...........................Software Loopback Interface 1
>  22...00 00 00 00 00 00 00 e0 Microsoft ISATAP Adapter
>  21...00 00 00 00 00 00 00 e0 Microsoft ISATAP Adapter #2
>  23...00 00 00 00 00 00 00 e0 Microsoft ISATAP Adapter #3
>  17...00 00 00 00 00 00 00 e0 Teredo Tunneling Pseudo-Interface
>  24...00 00 00 00 00 00 00 e0 Microsoft ISATAP Adapter #4
> ===========================================================================
> 
IPv4 Route Table
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0     192.168.42.1    192.168.42.76     30
        127.0.0.0        255.0.0.0         On-link         127.0.0.1    306
        127.0.0.1  255.255.255.255         On-link         127.0.0.1    306
  127.255.255.255  255.255.255.255         On-link         127.0.0.1    306
      192.168.1.0    255.255.255.0         On-link      192.168.1.10     12
     192.168.42.0    255.255.255.0         On-link     192.168.42.76    286
    192.168.42.76  255.255.255.255         On-link     192.168.42.76    286
   192.168.42.255  255.255.255.255         On-link     192.168.42.76    286
  255.255.255.255  255.255.255.255         On-link         127.0.0.1    306
  255.255.255.255  255.255.255.255         On-link     192.168.42.76    286
  255.255.255.255  255.255.255.255         On-link      192.168.1.10    266
===========================================================================
Persistent Routes:
  Network Address          Netmask  Gateway Address  Metric
      169.254.0.0      255.255.0.0    192.168.1.101       1
===========================================================================
    Persistent Routes:
      Network Address          Netmask  Gateway Address  Metric
          169.254.0.0      255.255.0.0    192.168.1.101       1
              0.0.0.0          0.0.0.0      192.168.1.1  Default
    ===========================================================================

1 Answer 1

1

You have good approach with assigning IP 192.168.1.10/24 to the interface. The extra route rule I see a little bit problematic. What you need is just set up IP and netmask on the interface (no GW, no extra rule). Let's check it step by step ;-)...

Just by assigning this IP there is implicit route record created:

192.168.1.0    255.255.255.0         On-link      192.168.1.10    266

As you have added also default GW, there is this route (shouldn't be there):

    0.0.0.0          0.0.0.0      192.168.1.1     192.168.1.10    266

You have created incorrect rule by adding the route :

route ADD 192.168.1.1 MASK 255.255.255.255 192.168.1.1 IF 10

192.168.1.1  255.255.255.255      192.168.1.1     192.168.1.10     11

As it is directly reachable it make no sense to send traffic to the GW with that IP (the result of this rule is not what you think). In case you want to have the rule there, it would be "On-link" and not GW 192.168.1.1.

As you don't want to route any traffic to the router (at least yet) there would not be any stuff pointing to this IP in field GW (3rd collumn).

In case it is still not working the problem would be in "filtered" rules - the rules you didn't post...

E.g.:

     0.0.0.0          0.0.0.0     192.168.42.1    192.168.42.76     30

but there is missing anything related to 192.168.42.x... something like:

192.168.42.0    255.255.255.0          On-link    192.168.42.76     30
7
  • @ok i have added full route table and also i have removed some rules
    – user889030
    Mar 11, 2020 at 15:45
  • so how can i delete : 0.0.0.0 route for the 192.168.1.1 gateway , as route delete 0.0.0.0 will delete both routes and will disconnect me
    – user889030
    Mar 11, 2020 at 15:48
  • 192.168.1.0 255.255.255.0 On-Link 192.168.1.10 route rule should be there (it is added automatically with adding IP). The ''0.0.0.0'' is not there in case you don't set "default GW" on interface. So with "clear" system simply add IP/netmaks on the interface (no extra additional rule, no default GW on that interface).
    – Kamil J
    Mar 11, 2020 at 16:23
  • The "problematic" are rules with 192.168.1.1 on the column Gateway. The correct rules (may be more) are "On-link". ;-)
    – Kamil J
    Mar 11, 2020 at 16:27
  • ok i added 192.168.1.0 255.255.255.0 On-Link 192.168.1.10 , but 192.168.1.1 is still not loading , i have updated route tables in Question , can you please have a look
    – user889030
    Mar 11, 2020 at 17:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.