I have a Linux based (Debian 5.0) NAS that I need to shutdown reliably. When ssh'd into the NAS box I issue the following command:

sudo shutdown -h now

I've also tried 'poweroff' and su'ing into root and running the commands with the same results. It shuts down all the processes and everything fine but does not always 'halt' the system. I need it to power down into the S3 state so that I can reliably use Wake On LAN to start the unit as needed. For what it's worth, wol works great and works every time as long as the unit is in it's S3 state.

  • 2
    I have seen this before on slightly older hardware. The issue is 100% related to any ACPI/APM settings you have in BIOS, the age of the motherboard, and the quality of the BIOS as well. Older/cheaper boards tend to have this (as ACPI and soft-poweroff were still somewhat new); newer systems have never exhibited this issue in my experience. May 20, 2009 at 7:44
  • This is an older Intel baseboard, the D945PVS. It's BIOS is the latest (version 0108 dated 08-17-2008) and it's configuration seems to be set correctly. I do have a slightly newer Intel board, a 955X chipset model that I could swap it with but I was hoping to avoid that pain. Thanks for giving me the answer I didn't want but is probably the most accurate.
    – user3146
    May 21, 2009 at 14:43

4 Answers 4


Humm could be a number of things. First thing I would try is to pass either


or even


to the kernel command line to see either of them works.

Next I would try unloading the wireless drivers before you shutdown (if possible).


Try the halt -p or poweroff commands.


I finally diagnosed the problem with this particular NAS backup server. It appears that the graphics card died at some point. Since this unit is run remotely via ssh it's only two lifelines are it's ethernet cable and it's power cord. Consequently, the dead graphics card went totally unnoticed. Putting in a new graphics card has solved the problem completely. I also did a lot of work to the unit to make sure that it has better airflow and much less heat build up since it is located in a place that is not very well ventilated and I believe that this may have been the cause of the graphics card failure. It could have just been the age of the graphics card but since I had the unit out I decicded to update/upgrade it's thermal properties just to be on the safe side.

  • weird, but glad it works! Jun 23, 2009 at 21:10

I have had similar problems, I just issue a halt instead, and it seems to work fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.