0

I have centos 8.1.1911 (core)

I can't get opensshd to run. I have dnf.

I removed it dnf remove openssh-server
then reinstalled dnf install openssh-server

systemctl start sshd

job for sshd.service failed for because hte control process exited with error code.

Going through the /var/log/messages log and I see a possible error I did sshd -t and got the same error, error is:

Failed to seed from getrandom: Function not implemented

journalctl -xe and systemctl status sshd.service show no other failures

sshd.service main process exited code=exited status=255/n/a Failed to start openssh server daemon

I did dnf remove openssh-server and tried again, still no luck

Removed /etc/ssh folder
rm -rf /etc/ssh
To wipe away any bad config and tried again. No luck

Care to advise? Does the centos 8.1.1911 just simply have no way to do this yet?

I saw a comment online to try this:
mkdir -p /var/run/sshd

For what I believe for PID file generation but having no luck still.

1

One possible reason could be when you upgraded the OS from CentOS 7 to CentOS 8 some of the code and commands that might have been defined in the sshd_config which are not compatible with CentOS 8. To know more check the access.log in /var/log PATH. Reinstalling sshd or openssh server doesn't remove the complete instance. Due to that, it may not work in many situations. The best way is to check the logs and sshd_config file.

| improve this answer | |
0

It's a little too late but if the problem is the result of a dist upgrade it's probably a kernel problem, you must upgrade your kernel version. Check yours with

uname -a

if =< 3.x you should try an upgrade

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.