1

I downloaded as Administrator in Chrome an installer .msi file [Citrix XenCenter Management; so it's not an exotic program] on a Windows Server 2012 R2 into a drive F: which is hosted on the SBS and mapped to the Windows Server 2012 R2 Terminal Server session while the login process.

When I double click this file I get this error message:

enter image description here

So, I list these strange facts which somehow tell me this may be a stupid security setting but I am not capable to solve it:

  1. Copying this file into the Desktop it gets executed and installed.
  2. Running this file in SBS from the original location [which is then mapped while the login process] gets also executed and installed.
  3. In this directory there are other .msi files which get executed/installed but also some of them have exactly the same issue and display the error message.

I deactivated the Windows SmartScreen and Network Access Protection Agent but no success.

My question:

How can I fix this issue so these .msi files are installed?

Update:

Once the program has been installed [when I ran it from the Desktop location] then suddenly the .msi file in the mapped drive can be executed, so I get the selections to modify or remove the program.

4
  • Ah, log? Run installer from command line with the flags for writing an output log. Start trying to understand it (it is very convoluted) and find the error. – TomTom Mar 19 '20 at 18:43
  • Closing: Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. – TomTom Mar 19 '20 at 18:43
  • @TomTom Thank you for your comment. Because of it I could fix the issue and I answered my question. If you down voted it may be you could reconsider to undo it... – Peter VARGA Mar 19 '20 at 20:20
  • Fu** - so a ramdisk tool caused it. That is definitely special. – TomTom Mar 20 '20 at 7:49
2

First, I want to thank TomTom regarding his hint running the installer from the command line with the log flags. I wasn't aware of this.

In my case the problem was very trivial and was caused by the ImDiskToolkit which created a ramdisk in the memory and set the TEMP & TMP environment variables to the new mapped ramdisk drive.

when I checked the log files I saw there were these entries and then I realized few programs couldn't handle it and the installation failed.

MSI (c) (2C:54) [20:59:05:694]: Note: 1: 1402 2: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer 3: 2 
MSI (c) (2C:54) [20:59:05:712]: Error: Getting file path failed: G:\Temp\6\1635c436.msi, error = 1
MSI (c) (2C:54) [20:59:05:712]: Error: Getting file path failed: G:\Temp\6\1635c436.msi, error = 1
MSI (c) (2C:54) [20:59:05:712]: Error: This file path is updated, hence failing to create: G:\Temp\6\1635c436.msi
MSI (c) (2C:54) [20:59:05:712]: Note: 1: 1310 2: 110 3: G:\Temp\6\1635c436.msi 

After uninstalling ImDiskToolkit all of these .msi installation files worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.