1

Environment: all Windows 10 stations, AD on Windows Server 2012 R2.

I am aware of File Extensions GPP. But in this particular network I am not being able to deploy a simple file to the computers (I'm trying to deploy to computers and not users, also I am trying to deploy to specific computers, so I'm putting the File Extensions GPP on a specific OU).

So, in the OU where the computers are, as a test, I tried to deploy a wallpaper JPG to C:\Windows\Web\Wallpaper\Windows.

So, on File Preferences (Computer Policy -> Preferences -> File) I entered:

   Action: Create
   Source File: UNC to where the JPG is (public share, no access restrictions)
   Destination file: C:\Windows\Web\Wallpaper\Windows\image.jpg

Destination file does not exist, and we are creating a file, so there would be no errors thrown.

The GPP just sits there, does nothing. Tried gpupdate /force on some stations, to no avail. Any guess on what I'm doing wrong? I'm a Unix guy, this Group Policy thing is very confusing to me.

GPP File Extensions

2
  • 2
    Check that the Share Permissions and the File Permissions of the source \\share\ allow read access from the Computer account or Domain Computers group
    – jfrmilner
    Mar 23, 2020 at 23:08
  • \\share\comum is universal, everyone has rights. Still. it wasn't working, so I put the file in SYSVOL. It worked there. Still don't know why.
    – Henrique
    Apr 2, 2020 at 14:20

1 Answer 1

0

After fiddling with permissions on the shared folder to no avail, I decided to follow Microsoft's advice I read somewhere (sorry, I lost the URL) and put the file on:

\\AD_HOSTNAME\SYSVOL

It worked there.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .