0

I'm trying to set up a MediaWiki instance secured with Keycloak. I used the descriptions for the needed plugins (PluggableAuth and OpenID Connect).

But when I set this up, I get an internal server error if I enter the Login page.

In the logs I have found the following thing:

[exception] [84a4c18a61e582a2d3729b6c] /index.php?title=Spezial:PluggableAuthLogin   Error from line 136 of /var/www/virtual/wiki/extensions/OpenIDConnect/src/OpenIDConnect.php: Class 'Jumbojett\OpenIDConnectClient' not found
#0 /var/www/virtual/wiki/extensions/PluggableAuth/includes/PluggableAuthLogin.php(30): OpenIDConnect->authenticate(NULL, NULL, NULL, NULL, NULL)
#1 /var/www/virtual/wiki/includes/specialpage/SpecialPage.php(575): PluggableAuthLogin->execute(NULL)
#2 /var/www/virtual/wiki/includes/specialpage/SpecialPageFactory.php(611): SpecialPage->run(NULL)
#3 /var/www/virtual/wiki/includes/MediaWiki.php(296): MediaWiki\Special\SpecialPageFactory->executePath(Title, RequestContext)
#4 /var/www/virtual/wiki/includes/MediaWiki.php(900): MediaWiki->performRequest()
#5 /var/www/virtual/wiki/includes/MediaWiki.php(527): MediaWiki->main()
#6 /var/www/virtual/wiki/index.php(44): MediaWiki->run()
#7 {main}

Anyone else maybe had this issue and know how to fix it? I already tried:

  • Check if dependencies are installed correctly -> alright
  • PHP version -> compatible (7.3)
  • asking Google -> found no results specific to that issue
  • Probably an issue with depedencies, nevertheless. Did you verify that the missing class exists on disk? Can you autoload it manually? – Tgr Mar 27 at 9:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.