0

We have several HPE Proliant DL580 G8 servers which give us a huge headache. They are second hand and thus have no warranty/support and don't know what they we're used for.

We've updated the server BIOS and reset to factory setting and then set, UEFI Mode. Updated the internal RAID Controller P830i to the latest Firmware and set it to HBA as we want the OS to read SMART data. Now we booted an ISO installer through a virtual drive. The disks attached to the P830i were visible and the OS (tried: Virtuozzo, Red Hat, ESXi, Ubuntu) was installed successfully and needed to reboot/boot from the disk the first time which fails with a message saying no bootable disk found. We tried changing Boot Mode to Legacy BIOS and installed again with the same problem in the end. We also tried using some LSI Controller we had laying around, same thing there. Disks are visible but won't boot.

We have no clue what's going on. Has anyone else had the same experience and more important could anyone resolve this? Any tips would be much appreciated!

  • What version of these OSes are you using? – Bert Mar 27 at 13:24
  • Are you using HP disks or something off the shelf from another manufacturer? – Dave M Mar 27 at 15:28
0

Try this method as it worked for me.

During Server boot, press F9. Scroll down and select the "Run a UEFI application from a file system" entry. Select the boot device. Keep selecting the entries to return to the corresponding boot loader to boot the OS.

P.S : I had the same issue on HP DL580 Gen8 SUSE Linux 11 SP4

| improve this answer | |
  • Hi Muhammad God bless you! That was it, after installing these OS with UEFI I am able to boot via your recommended way! Thank you and everyone else who took the time! – Flow Mar 30 at 10:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.