0

I took snapshot of OS-Disk and migrated it to other subscription. Created a Disk out of Snapshot, Tried creating VM out of the new disk using portal.

Deployment got failed with following error. Initial VM was created by Azure marketplace image. I am not understanding whats wrong here. Help me to understand whats wrong here.

Error: {"code":"DeploymentFailed","message":"At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/DeployOperations for usage details.","details":[{"code":"Conflict","message":"{\r\n \"status\": \"Failed\",\r\n \"error\": {\r\n \"code\": \"ResourceDeploymentFailure\",\r\n \"message\": \"The resource operation completed with terminal provisioning state 'Failed'.\",\r\n \"details\": [\r\n {\r\n \"code\": \"VMMarketplaceInvalidInput\",\r\n \"message\": \"Creating a virtual machine from Marketplace image requires Plan information in the request. VM: '/subscriptions/1bf608d4-1499-4732-8948-2c629b705e8d/resourceGroups/ai-ds-vm/providers/Microsoft.Compute/virtualMachines/eureka-ds-dev-a'.\"\r\n }\r\n ]\r\n }\r\n}"}]}

Best Regards, Suraj

0

Error indicate that you create it VM initially with a Markeplace email that has a Plan.

If SKU plan still exist you will need to use it to recreate VM, if it no longer exist you will not be able to recreate VM. Below is a link to another forum that goes through the recreation options.

https://stackoverflow.com/questions/55733411/how-to-fix-azure-portal-not-deploying-a-vm-from-image-due-to-no-plan-error

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.