I have four HDDs in my NAS.

Three (Western Digital, all the same model) are put in standby mode (spin down) by hd-idle and they stay in standby until I use them. The reason I use hd-idle and not the internal power saving mechanism via hdparm (-S XX /dev/smth) is that those drives do not support it.

Here comes the problem: The forth (Toshiba) can be spun down by hd-idle and also manually by hdparm (-y /dev/drive4) but wakes up after around 30 minutes (sometimes sooner, sometimes later)...every time. I tried various things:

Shut down hd-idle all together. (Maybe it causes the wake-ups somehow). Did not work.

Try different settings for hdparm -S XX /dev/drive4 (internal standby time) and hdparm -B XX /dev/drive4 (internal power management settings). Nope, still wakes up after a while.

Check iostat if the drive was used by somethings. No usage what so ever. Everything is unmounted. Also the drive is part of an LVM volume group and FS with the other drives in the system and I am fairly positive that if some process would wake up the drive, it would also wake up all the other drives.

I have no clue what's going on here. Has anyone experienced this? How can I enhance my debugging?

On a side note: I know that spinning HDDs up and down constantly is bad, but I sometimes do not need the drives for long periods of time and would rather have them be in standby for this duration.

1 Answer 1


Info: I figured it out and will post a longer answer in a couple of days when i have the exact information on the situation, but first a short answer.

Short answer: I am using Debian 10 (Buster) and if either smartd.service or lvm2-monitor.service is running, the drive in question will be woken up from sleep regularly.

smartd should ONLY schedule a SMART test once a week on all drives (which it does) and all the other drives do not experience any regular out-of-schedule wake-ups, just one of four.

lvm2-monitor.service also wakes up the drive regularly. Again, the other three drives do not care. The setup of the drives is the same for all of them. (GPT -> LUKS -> LVM -> FS)

I do not see the immediate reason for this behavior, but it is fixed.

Long answer: Will come soon(TM)...

  • Is LVB2-monitor.service necessary or can it be disabled although having a lvm running? Jul 26 at 5:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .