2

I have a MySQL database on AWS. Here are some of the settings:

  • DB instance id - database-2
  • Endpoint - database-2.***.eu-central-1.rds.amazonaws.com
  • Port - 3306
  • Public accessibility - true
  • DB name - testdb
  • Master username - admin

Now I am trying to connect to that database using DBeaver. Here is the screenshot of the settings I used:

settings I used.

I am getting "connection timed out" error. I tried with Database: testdb, but I get the same error. What can I do to fix that?

Note: DBeaver works fine with other databases.

2
  • Also, please edit the image into the post, as I am not allowed to post images
    – Rasmond
    Apr 2, 2020 at 19:04
  • Have you confirmed that your firewall is allowing you to connect? Port / IP allowed. You do have a firewall in place?
    – John K. N.
    Apr 3, 2020 at 11:57

1 Answer 1

1

Turns out the reason was inbound rules set for security group. Here is a detailed answer about that: https://serverfault.com/a/656119/567809

The proper connection details for DBeaver for me were:

  • Server Host: Endpoint address
  • Port: 3306
  • Database: DB name
  • User name: Database master username
  • Password: Database master password

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.