Yes the title is correct! A long time a go a website was developed for a student association, the website now has some historical meaning. I'm trying to move the website do a different server, with Docker, but this is a bit harder that I anticipated.

I can't find any repositories with this PHP version. So I tried compiling it from this source: http://museum.php.net/php5/php-5.1.6.tar.gz. Then I ran into another problem. All dependencies of this PHP version are old, and I cannot find software repositories with the right versions.

I did found a working php 5.1.6 Dockerfile: https://github.com/nubs/docker-php-minimal/tree/master/php-5.1.6. But here I still have the problem when I add php extensions that have dependencies.

How can I get a working php 5.1.6 installation in Docker?

This is the php configure command of the working installation:


Have you tried with a newer release? Perhaps not brand new, but something slightly newer? There is still a php:5.4-apache image tagged in the docker library images.

Past that, you may have to build a 5.1.6 image on Linux release that has a similar release time.

Still I hope you have this software in a read-only configuration. A system that old is almost certainly exploitable, and could be attacked and quickly compromised.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.