I have tried all the steps in https://askubuntu.com/questions/3913/start-ssh-server-on-boot to no avail.

I want to be able to login via SSH on my tablet over the WiFi connection. It works after being logged in at the physical machine but not before. Otherwise it just comes up with connection refused.

Any ideas what to try next?

  • Its this any help? askubuntu.com/questions/1277/…
    – john
    Apr 21, 2020 at 5:08
  • I don't know. I had a look under Kubuntu "system settings" and then under Network wireless connections and there was no option to start wireless network on startup or boot. Apr 22, 2020 at 20:47
  • Turns out it was a wireless setting but it was a problem with gnome keyring Sep 6, 2020 at 6:11

1 Answer 1



systemctl enable sshd

It should start the sshd on boot.

or try re-installing it:

sudo apt-get remove openssh-server --purge

sudo apt-get install openssh-server

Than repeat sudo systemctl enable sshd

If the above doesn't work, try

sudo systemctl enable ssh.service

Also read: https://superuser.com/a/1069654

If it still doesn't work:

create a file called rc.local under the etc directory

The content of rc.local:

#!/bin/sh -e
sudo service network-manager start
sudo service ssh start
sudo service sshd start

Thén run sudo systemctl enable rc-local.service

Restart the system after editing.

  • Unfortunately that doesn't work for me . Here is what I got: $ sudo systemctl enable sshd Failed to enable unit: Refusing to operate on linked unit file sshd.service Apr 22, 2020 at 20:45
  • Sorry about not being able to format my answer. After only the second try it told me I wasn't allowed to edit it anymore. Probably not enough reputation points. Apr 22, 2020 at 20:51
  • Have you tried re-installing sshd
    – Algo7
    Apr 22, 2020 at 20:57
  • I have no idea how to do that reliably. Although I do know how to run apt commands from the command line if that's what you are asking. I am also on a slow internet connection which is probably going to cause me major headaches. Apr 22, 2020 at 21:09
  • I put it in the answer. Give it a shot. If it doesn't work, we do it the rc.local way
    – Algo7
    Apr 22, 2020 at 21:15

Not the answer you're looking for? Browse other questions tagged .