0

I'm attempting to get Brother HL-L2301-D printer running under Gentoo.

I've downloaded the RPM and installed it under Gentoo. The device is detected and I've set up a udev rule to make it available at /dev/usb/lp0, although it now appears there not as a symbolic link as it did yesterday but is still present at that location

# lsusb | grep -i brother
Bus 001 Device 100: ID 04f9:009a Brother Industries, Ltd HL-L2310D series
# l /dev/usb/lp0 
crw-rw---- 1 root lp 180, 0 Apr 21 10:24 /dev/usb/lp0

I've tried adding the printer in two ways after reading this thread that suggested using the usb://Brother/HL-L2310D%20series?serial=### rather than usb://dev/usb/lp0...

# lpadmin -p Chompy -E -v usb://Brother/HL-L2310D%20series?serial=E78096L9N400161 -i /usr/share/ppd/cupsfilters/brother-HLL2310D-cups-en.ppd -L "Study"
# lpadmin -p Chompy2 -E -v usb://dev/usb/lp0 -P /usr/share/ppd/brother/brother-HLL2310D-cups-en.ppd

The printer is turned on and lights indicate its "Ready", both Chompy and Chompy2 (daughter chose the name, quite perceptive for 6yo!) are listed in the CUPS WebUI and yet if I try to print a test page to either I'm told...

Processing - "Waiting for printer to become available."

Checking with lstat

# lpstat -o "Chompy" -p -l
Chompy-22               root              1024   Tue 21 Apr 2020 10:25:17 BST
printer Chompy now printing Chompy-22.  enabled since Tue 21 Apr 2020 10:25:17 BST
    Waiting for printer to become available.

Same happens if I try using Chompy2.

Stumped as to what to try next, any suggestions would be gratefully received. I'm keen to get this working and then share it on the network.

-1

in my case, this helped:

ls /dev/usb/lp0 gives /dev/usb/lp0

In Ubuntu 16.04: System > Printer > Choose your Printer > Properties

Change address from /dev/us/lp0 to usb, then click Apply.

1
  • This answer isn't complete, in that I have no idea what you're suggesting. Please add more so the answer can stand alone.
    – sysadmin1138
    Apr 15 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.