1

I have an old Windows server 2008 r2 that was a bare metal server converted to a vhd using Microsoft's Systernals's disk2vhd utility before the server was sunsetted. Fast forward to today, using hypervisor v under Windows 10, the VM comes up just fine except there's no internet connectivity since it has its original configuration. How can I configure this so that I can retrieve some content from the VM?

It is connected to a virtual switch: enter image description here

I deleted the network elements, rebooted, but now I cannot get the VM to recognize the network adapters. I thought reinstalling the adapter, the networking client (Client for Microsoft Networks), and TCP/IP that it'd come to life. No such luck.

I made a copy of the VM and preserved the original so I'm back to with with a fresh copy since I mucked up the first copy. :)

Network Adapter Properties

15
  • Is it connected to a virtual switch?
    – Davidw
    Apr 25 '20 at 0:04
  • @Davidw - yes; added image for reference.
    – HPWD
    Apr 25 '20 at 0:48
  • Did you install integration services on your VM?
    – Stuka
    Apr 25 '20 at 21:38
  • Hyper-V was installed a long time ago for another project and not sure if I installed that then. How can I find out?
    – HPWD
    Apr 26 '20 at 1:07
  • What type of virtual switch is it? (external, internal, or private)
    – Davidw
    Apr 26 '20 at 6:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.