3
# df -H
Filesystem                            Size  Used Avail Use% Mounted on
...
/dev/bcache4                          8.1T  1.9T     0 100% /mnt/8t4
# btrfs fi df -H /mnt/8t4
Data, single: total=1.84TB, used=1.82TB
System, DUP: total=33.55MB, used=212.99kB
Metadata, DUP: total=2.15GB, used=1.91GB
GlobalReserve, single: total=536.87MB, used=0.00B
# btrfs fi usage /mnt/8t4
Overall:
    Device size:                   7.28TiB
    Device allocated:              1.67TiB
    Device unallocated:            5.60TiB
    Device missing:                  0.00B
    Used:                          1.66TiB
    Free (estimated):              5.62TiB      (min: 2.81TiB)
    Data ratio:                       1.00
    Metadata ratio:                   2.00
    Global reserve:              512.00MiB      (used: 0.00B)

Data,single: Size:1.67TiB, Used:1.66TiB (99.26%)
   /dev/bcache4    1.67TiB

Metadata,DUP: Size:2.00GiB, Used:1.78GiB (88.98%)
   /dev/bcache4    4.00GiB

System,DUP: Size:32.00MiB, Used:208.00KiB (0.63%)
   /dev/bcache4   64.00MiB

Unallocated:
   /dev/bcache4    5.60TiB

I've tried various balances but they didn't help. There are two fairly recent snapshots on the fs.

How do I make Btrfs realize there's ~6TB of free space?

1
  • Perhaps showing the errors and balances might help someone diagnose the issue. – rickhg12hs Apr 29 '20 at 13:25
4

"General linux userspace tools such as df will inaccurately report free space on a Btrfs partition. It is recommended to use btrfs filesystem usage to query Btrfs partitions." https://wiki.archlinux.org/index.php/Btrfs

Output of btrfs fi usage shows 5.6TB as available, what looks resonable.

Explanations about free space - https://btrfs.wiki.kernel.org/index.php/FAQ#How_much_free_space_do_I_have.3F

1
  • 1
    That is probably what's happening since I can still manipulate files on the drive. However I have other programs relying on the standard interface that will misbehave if it indicates full. – Cobra_Fast Apr 29 '20 at 19:53
0

The problem was solved by rebooting into an updated kernel. Going from 5.4.8 to 5.6.7.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.