I know this question had been asked many times. I checked answers but none of them worked for me. I run this command

which nginx

And I get /usr/sbin/nginx

I try to navigate to that folder and I can see the nginx folder but it says Not a directory

I navigated to /etc/nginx/sites-available but can't access default directory or the domain direcroty I want and it keeps saying the same and I can't access them to make any edits. This is the first time I work on nginx server so please I need help here.

1 Answer 1


Its heavy to help you as there is a lot of information missing in your question. I'm not sure but i think you don't have PHP configured correctly in Nginx (or maybe not installed PHP at all?)

I recommend you to follow a good tutorial on the internet that explains you how you can setup a webserver on linux with Nginx, PHP and maybe MySQL like this one for example:


If there still things not clear after folowing such a tutorial you can open a new question but please be more concrete. What did you tried to solve your problem? How are your Nginx configurations and so on.

Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.