I'm having a weird problem on two Windows 2008 VMs (inside HyperV) running NLB. They were working at one point, but now TCP/IP appears to be corrupt. I cannot ping anything if logged in with my Domain Admin account:

Unable to contact IP driver, error code 5,

I tried resetting winsock and ip with netsh. That makes no difference:

netsh int ip reset
Resetting Echo Request, failed.
Access is denied.

I uninstalled NLB, I removed the synthetic NIC and added a legacy NIC from Hyper-V -- no dice.

The weird thing is that it works if I login with the built-in Administrator account, but not my Domain Admins account. UAC is disabled, so this should just work.

Any ideas apart before I call PSS?

Edit: Can't ping anything if I don't login with the built-in Administrator account. (UAC on or off makes no different.) Can't ping (access denied). NICs are the HyperV ones.

I installed SP2 for Windows 2008, no change.


I ran into this same problem on Server 2008, completely out of the blue. Tried the same steps as you also, with no luck. I ended up dumping the Winsock and Winsock2 settings from the registry from another (working) box and using those.

Download from here and here.

If you want to give it a shot, just back up HKLM\SYSTEM\CurrentControlSet\Services\WinSock and HKLM\SYSTEM\CurrentControlSet\Services\WinSock2 first to be safe. After you back those keys up, delete them from the registry, then import and reboot. Dumped from Server 2008 x86.

  • I should mention that my problem was also with virtualized Server 2008 (running on VMware Workstation 6.5). I had three Server 2008 VMs on a new forest/domain; Domain Controller, Exchange 2007 server, BES. My user account (Domain Admin) and the BESAdmin account could not ping on the BES, but the local Administrator could. Both BESAdmin and my account could run ping on other boxes. The referenced error message is not a firewall issue and it's not a permission issue as other users are suggesting. In my case the box responded to pings too, the problem was weird Winsock corruption. – Corey May 20 '09 at 13:56

I've run into a few things that still need you to 'Run as administrator' on Vista and Win2008. Even if UAC is disabled. Not sure why, but try it and see if it helps out.


  • Tried that too - no luck. – MichaelGG May 20 '09 at 1:24
  • The only other thing I can recommend is to update the drivers for your network card and see if that helps. – JFV May 20 '09 at 3:16

Can you ping localhost? If so then TCP/IP should be fine. Perhaps it's got a domain firewall setting enabled that it shouldn't have?

  • Nope. Can't ping anything - get the access denied error when trying to ping. Disabling the firewall doesn't seem to change anything. – MichaelGG May 20 '09 at 3:54
  • Not even local host? That's surprising. I'd give Corey's regkeys a try then. – mrdenny May 20 '09 at 5:55

Check the firewall is not blocking PING (ICMP - listed under file and printer sharing).

I had a similar problem previously where the host and virtual machine both had the firewall enabled and both were blocking PING, caused all kinds of havoc.

  • Even tried turning off the firewall - no luck. – MichaelGG May 20 '09 at 7:44

If your Firewall is enabled...you should enable File and Printer sharing.....File and printer sharing allow ICMP packets which is being used by PING


If you dont need Windows Firewall...make sure to turn it all off....3 levels...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.