0

I am having problems with dovecot on a debian 9 system running webmin/virtualmin.

After an update, it seems that the renewal of a domain SSL certificate caused at least one client domain to use the wrong domain ssl certificate for email...the all my problems started.

systemctl status dovecot.service returns...

    May 08 13:42:31 server1.domain.com.au doveadm[6252]: Fatal: Dovecot is not running (read from /var/run/dovecot/master.pid)
May 08 13:42:31 server1.domain.com.au systemd[1]: dovecot.service: Control process exited, code=exited status=75
May 08 13:42:31 server1.domain.com.au systemd[1]: dovecot.service: Unit entered failed state.
May 08 13:42:31 server1.domain.com.au systemd[1]: dovecot.service: Failed with result 'exit-code'.

I have tried to restart but i get errors.

So i did the following ps aux | grep dovecot

    dovenull  2313  0.0  0.1  21760  5832 ?        S    14:13   0:00 dovecot/imap-login
secreta+  2315  0.0  0.0  23876  3868 ?        S    14:13   0:00 dovecot/imap
dovenull  4936  0.0  0.1  21760  5636 ?        S    14:51   0:00 dovecot/imap-login
dovenull  4938  0.0  0.1  21760  5712 ?        S    14:51   0:00 dovecot/imap-login
members+  4952  0.0  0.1  23880  4476 ?        S    14:51   0:00 dovecot/imap
adamjed+  4953  0.0  0.1  23868  4572 ?        S    14:51   0:00 dovecot/imap
dovenull  5877  0.0  0.1  21748  5968 ?        S    14:53   0:00 dovecot/imap-login
contact+  6029  0.0  0.0  23536  3920 ?        S    14:53   0:00 dovecot/imap
root      6253  0.0  0.0  18132  2548 ?        Ss   13:42   0:00 /usr/sbin/dovecot
dovecot   6254  0.0  0.0   9492   944 ?        S    13:42   0:00 dovecot/anvil
root      6255  0.0  0.0   9624  2324 ?        S    13:42   0:00 dovecot/log
root      6257  0.0  0.3  29768 12660 ?        S    13:42   0:00 dovecot/config
liaison+  8815  0.0  0.1  23916  4380 ?        S    13:44   0:00 dovecot/imap
preside+ 10156  0.0  0.0  23896  3884 ?        S    14:21   0:00 dovecot/imap
dovenull 13538  0.0  0.1  21748  5636 ?        S    14:55   0:00 dovecot/imap-login
ajecrea+ 13549  0.0  0.1  23892  4468 ?        S    14:55   0:00 dovecot/imap
preside+ 14016  0.0  0.1  24488  4960 ?        S    14:25   0:00 dovecot/imap
dovecot  15172  0.0  0.0  20520  2788 ?        S    14:57   0:00 dovecot/auth
root     19500  0.0  0.0   4276   716 ?        S    15:00   0:00 sh -c (ps aux | grep dovecot) 2>&1
root     19501  0.0  0.0   4276    88 ?        S    15:00   0:00 sh -c (ps aux | grep dovecot) 2>&1
root     19503  0.0  0.0  11104   928 ?        S    15:00   0:00 grep dovecot
dovenull 20675  0.0  0.1  21748  5624 ?        S    14:32   0:00 dovecot/imap-login
contact+ 20686  0.0  0.1  23948  4516 ?        S    14:32   0:00 dovecot/imap
dovenull 23780  0.0  0.1  21748  5636 ?        S    14:34   0:00 dovecot/imap-login
contact+ 23782  0.0  0.1  24592  5160 ?        S    14:34   0:00 dovecot/imap

After forcing dovecot to completely shutdown i then run systemctl restart dovecot

systemctl status dovecot returns the following after a successful dovecot restart

   # ps aux | grep dovecot
root     31916  0.0  0.0  18000  2520 ?        Ss   15:39   0:00 /usr/sbin/dovecot
dovecot  31917  0.0  0.0   9492   988 ?        S    15:39   0:00 dovecot/anvil
root     31918  0.0  0.0   9624  2284 ?        S    15:39   0:00 dovecot/log
root     31921  0.0  0.1  25176  7136 ?        S    15:39   0:00 dovecot/config
dovecot  32001  0.0  0.0  20520  2524 ?        S    15:39   0:00 dovecot/auth
root     32002  0.0  0.0  33204  3768 ?        S    15:39   0:00 dovecot/auth -w
root     32166  0.0  0.0   4276   748 ?        S    15:40   0:00 sh -c (ps aux | grep dovecot) 2>&1
root     32167  0.0  0.0   4276    88 ?        S    15:40   0:00 sh -c (ps aux | grep dovecot) 2>&1
root     32169  0.0  0.0  11104   920 ?        S    15:40   0:00 grep dovecot

However, after users try to reconnect their email client apps with my mail server, dovecot eventually stops working again (did this after about 30 mins last time).

I am now at a mental blank and need help.

0

is there no one with a solution to this? I am still having problems...here is the latest mail log...i dont understand why these errors are shutting down the dovecot status monitor on my debeian server.

can someone got through this error log and explain to me exactly why these particular errors are appearing. (the ipaddress is left as is in the error log…it is not a known ipaddress to me)

May 20 14:16:02 server1 dovecot: anvil: Fatal: master: service(anvil): child 1941 killed with signal 9 May 20 14:16:12 server1 dovecot: imap-login: Fatal: master: service(imap-login): child 25826 killed with signal 9 May 20 14:16:12 server1 dovecot: anvil: Error: connect limit: disconnection for unknown pid 25828 + ident imap/103.129.156.70/operations@domain1.com May 20 14:16:20 server1 dovecot: auth: Error: net_connect_unix(anvil-auth-penalty) failed: Permission denied May 20 14:16:20 server1 dovecot: auth: Error: auth worker: Aborted PASSV request for operations@domain1.com: Shutting down May 20 14:16:26 server1 dovecot: imap-login: Fatal: master: service(imap-login): child 4394 killed with signal 9 May 20 14:16:26 server1 dovecot: anvil: Error: connect limit: disconnection for unknown pid 4395 + ident imap/52.125.136.93/contact@domain3.com May 20 14:16:37 server1 dovecot: anvil: Error: connect limit: disconnection for unknown pid 9749 + ident imap/52.125.130.11/secretary@domain1.com May 20 14:16:37 server1 dovecot: imap-login: Fatal: master: service(imap-login): child 9748 killed with signal 9 May 20 14:16:45 server1 dovecot: anvil: Error: connect limit: disconnection for unknown pid 28250 + ident imap/52.125.136.93/contact@domain3.com May 20 14:17:18 server1 dovecot: master: Fatal: Dovecot is already running? Socket already exists: /var/run/dovecot/login/login May 20 14:18:06 server1 dovecot: anvil: Error: connect limit: disconnection for unknown pid 7074 + ident imap/52.125.130.11/secretary@domain1.com May 20 14:19:01 server1 dovecot: anvil: Error: connect limit: disconnection for unknown pid 15213 + ident imap/120.146.145.157/adamjedgar@domain2.com May 20 14:19:16 server1 dovecot: anvil: Error: connect limit: disconnection for unknown pid 25509 + ident imap/1.129.106.62/contact@domain3.com May 20 16:34:31 server1 dovecot: master: Error: unlink(/var/run/dovecot/master.pid) failed: No such file or directory (in main.c:558) May 21 01:19:36 server1 dovecot: master: Fatal: Dovecot is already running? Socket already exists: /var/run/dovecot/login/login May 21 01:19:38 server1 dovecot: master: Fatal: Dovecot is already running? Socket already exists: /var/run/dovecot/login/login May 21 01:19:40 server1 dovecot: master: Fatal: Dovecot is already running? Socket already exists: /var/run/dovecot/login/login May 21 01:19:42 server1 dovecot: master: Fatal: Dovecot is already running? Socket already exists: /var/run/dovecot/login/login May 21 06:33:31 server1 dovecot: master: Fatal: Dovecot is already running? Socket already exists: /var/run/dovecot/login/login

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.