1

I have successfully implemented a Folder Redirection group policy for a specific user group in our organization; however, the folders are not being redirected as expected. My goal is to implement the redirection such that a users 'Documents' folder will appear in the location \\storagebox\users$\%username%\Documents. I also have set the users home folder to \\storagebox\users$\%username%.

This is working for all other redirected folders except the Documents folder itself. For example: The 'Pictures' folder is found at \\storagebox\users$\%username%\Pictures. For some reason, however, the %username% container folder itself has been converted into the 'Documents' folder, while also housing the other folders.

If a user opens their 'Documents' folder, they are transported to their 'Home' folder, and the folder structure is as follows:

Users/
|  User.One/
|  |  Desktop/
|  |  Downloads/
|  |  Music/
|  |  Pictures/
|  |  Videos/
|  |  File1.txt
|  |  File2.txt
|  |  . . .
|  User.Two/
|  . . .

I have tried:

  • Setting 'Redirect to the following location' to \\storagebox\users$\%username%\Documents.
  • The option to "Redirect to the user's home directory."
  • Setting 'Create a folder for each user under the root path' to \\storagebox\users$
    • Even the example text for this identifies the destination for the 'Documents' folder as
      \\storagebox\users$\Claire\Documents

I have also made sure that the group policy is successfully updated after every attempted adjustment.

In the end I would like the tree structure of the 'Home' folder and the redirected user folders to be as follows:

Users/
|  User.One/
|  |  Desktop/
|  |  Documents/
|  |  |  File1.txt
|  |  |  File2.txt
|  |  |  . . .
|  |  Downloads/
|  |  Music/
|  |  Pictures/
|  |  Videos/
|  User.Two/
|  . . .

The only folder not following the wanted pattern is the users 'Documents' folder and I can't seem to figure out why. How can I get the desired implementation to work?

2 Answers 2

2

The reason this is happening is because the the original GPO has set the folder locations in USER registry for that login session.

If you apply a new GPO, the change will not happen. Eg. (Documents)

OLD = Redirect to Users home dir

NEW = Create a folder for each user under root path.

So the files will not be moved from "Home" to "HOME\My Documents) It won't even create a "My Documents" folder.

If you want to quickly resolve this.
Just delete the user profile on the PC or RDP server. Next time the user logs in, it will pick up the new GPO. Or like you did.
Change the GPO to 'Redirect to the local user profile location'

The reason both ways work. Is because the location of the Documents section has changed to a completely separate location. That being not within the same folder structure.

Interestingly.
If the user logs into a different PC or RDP server for the first time. The NEW GPO settings will actually work. And will even create the "My Documents" folder. However it will not move the files. And if you login to the original PC or RDP server again, the My Documents section will remain in the original settings. That being "Home" not "Home\My Documents"

Basically... The new GPO "My documents" redirect, will only work on NEW LOGINS, without an existing user profile. Or a profile that hasn't previously redirected to users home dir. Each login session (PC or RDP), retains the first saved "My Documents" location for the user and won't be changed by GPO if its with the same folder structure.

The key here is are these settings. https://support.microsoft.com/en-us/topic/operation-to-change-a-personal-folder-location-fails-in-windows-ffb95139-6dbb-821d-27ec-62c9aaccd720

You can even change the USER Documents Reg entry to reset, if you don't want to blow away the entire profile to reset locations.

0

While I am still unsure as to what was causing the issue, I was able to resolve it through the following steps:

  1. Change the GPO to 'Redirect to the local user profile location'.
  2. Forcing a gpupdate for all users in the applicable group.
  3. Having all users log in to apply the GPO.
  4. Change the GPO back to 'Create a folder for each user under the root path'.
    • Setting the root path to \\storagebox\users$
  5. Repeat steps 2 and 3

If someone else has an answer that is able to explain why this happened, I will gladly accept that answer. Following these steps worked for me, so I wanted to provide them in case someone else experiences this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.