0

I see this error since some time. But no details. I run chkdsk on all disks and don't see any problems. Is there a problem with one of the disks? Which one?

enter image description here

enter image description here

1

From the picture there doesn't seem to be any issues. Going into detail though, I would suspect this error being tricked by one of a number of possible factors (from historic experience, I can think of a few).

You wouldn't by any chance use USB harddrives (which show up as fixed disks) from time to time on this system? This can trigger a dirty-bit set detection.

Anyhow - if you want to check the dirty bit status of all your volumes (a dirty bit detected, is ultimately what triggers the event), you can open an administrative powershell prompt, and run the following command:

  1. Diskpart
  2. Type "list vol"
  3. exit

It will display information similar to the following:

PS C:\> diskpart

Microsoft DiskPart version 6.3.9600

Copyright (C) 1999-2013 Microsoft Corporation.
On computer: G-PC

DISKPART> list vol

  Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
  ----------  ---  -----------  -----  ----------  -------  ---------  --------
  Volume 0     E   SSD_DATA     NTFS   Partition    953 GB  Healthy
  Volume 1     R   R_RECOVERY   NTFS   Partition    223 GB  Healthy
  Volume 2     C   C_SYSTEM     NTFS   Partition     99 GB  Healthy    Boot
  Volume 3     D   D_DATA       NTFS   Partition    272 GB  Healthy
  Volume 4         Recovery     NTFS   Partition    300 MB  Healthy    Hidden
  Volume 5                      FAT32  Partition     99 MB  Healthy    System

DISKPART> exit

Leaving DiskPart...
PS C:\>_

You may also use powershell and WMI, however it will not show you the EFI partition, but that one will not have a dirty bit anyway (its FAT):

PS C:\> gwmi win32_volume|ft DirtyBitSet,DriveLetter,Label,FileSystem,DriveType,@{N="CapacityGB";E={"{0:0.00}" -f ($_.Capacity/1GB)}},DeviceID -auto

DirtyBitSet DriveLetter Label      FileSystem DriveType CapacityGB DeviceID
----------- ----------- -----      ---------- --------- ---------- --------
      False E:          SSD_DATA   NTFS               3 953,87     \\?\Volume{7f6ac413-3dac-11e6-824c-806e6f6e6963}\
      False R:          R_RECOVERY NTFS               3 223,44     \\?\Volume{3413706d-6399-434e-a8da-e15040605ade}\
      False C:          C_SYSTEM   NTFS               3 99,48      \\?\Volume{904973b0-8eeb-4964-b69b-446d0ec54fd7}\
      False D:          D_DATA     NTFS               3 272,61     \\?\Volume{76a3823b-2319-4bb5-b604-ceca62d17ffa}\
      False             Recovery   NTFS               3 0,29       \\?\Volume{5c943c90-32ac-4ff6-b5cc-abbe56321078}\
      False             Boxcryptor NTFS               4 953,87     \\?\Volume{998eb5d7-542c-11e8-8354-d017c2d490d4}\


PS C:\>_

If any of the above shows anything else than "Healthy" or DirtyBitSet = False, then you should target the disk containing that volume.

If all is healthy, then you can disregard the event.

2
  • Thanks, I tried and all is healthy and fine - but the critical alert still shows. Strange...
    – Edgar
    May 25 '20 at 2:56
  • 1
    If you have checked all ok according to above instructions, I for one personally wouldn't worry. Seems like an M$ oddity more than anything else.
    – Sharza
    Jun 4 '20 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.