I spent serveral hours getting Cygwin, OpenSSH and Gitosis to work together on Windows Server 2008 x64 - unfortunately the tutorials on the web (from e.g. Shannon Cornish) don't seem to have an answer to my problem.

I get the following trying to login to my "git" user via SSH or trying to checkout the repository via "git clone git(at)localhost:gitosis-admin.git"

[main] sshd 9364 C:\cygwin\usr\sbin\sshd.exe: *** fatal error - could not load user32, Win32 error 1114 fatal: The remote end hung up unexpectedly

I found some hints that the I have to set serveral group policies regarding user tokens - but doing so didn't help either...

up vote 1 down vote accepted

I've run into the same problem, both with Shannon Cornish's approach and with Tim Davis' approach. I'm still stuck.

Have you tried Tim Davis' approach as well? I've read on various cygwin-related sites that if the SSH daemon is running (indirectly) as a Windows administrator then this problem goes away. I'm running cygwin/sshd as a user who's in the admin group, so has full privileges to all files but I still get the same Win32 error 1114 as you.

Please post back if you've resolved the problem or if any of either of my pointers works for you.


A Cygwin dev describes the relationship between cyg_server, Win32 errors, and Domain security. I haven't fully ruled this out as the cause but in my case I'm not trying to SSH using a Domain user so it sounds like it wouldn't be an issue.

Also, in case it helps: Mark Embling describing similar setup to Shannon's but continuing into more detail on Gitosis

  • Simon B's answer worked for me. I had originally configured cyg_server and SvcCOPSSH to be in the Administrators group but adding the git user did the trick. Would vote Simon B up but don't have enough rep yet. – jlpp Feb 3 '10 at 14:42
  • Thanks for the hint I'll try getting it to work later this week - I had a project that needed to get done, so I decided to use a Debian VM as a temporary solution. – backyardKiwi Feb 23 '10 at 10:09
  • None of these helps. I even tried checking with Process Monitor--nothing special there. The solution is to add git to "Administrators" group, and disable logging in with sshd built-in capabilities. – P Shved Mar 11 '10 at 13:35

I had this error and solved it by giving my "git" ssh user membership in group Administrators. The hint to do this came from http://www.cygwin.com/ml/cygwin/2008-07/msg00276.html

  • Actually this is something I'd like to prevent for security reasons - but I'll give it a try to see if it helps at all in my case. – backyardKiwi Feb 23 '10 at 10:12

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.