3

I'm new to zabbix and I'm trying to create custom User Parameter to Monitor CPU utility per process(Windows Machine).

I have a powershell script and a user parameter, I also added a new item under zabbix -> Configuration -> hosts, but I keep getting the Not Supported status and I ran out of potential blogs/solutions to help me.

Does anyone have an idea on what I'm missing / doing wrong ?

My user Parameter : UserParameter=checkcpuperprocess[*], C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -ExecutionPolicy Bypass -file C:\Zabbix\conf\CPUperProc.ps1

My powershell script :

    $properties=@(
        @{Name="Process Name"; Expression = {$_.name}},
        @{Name="CPU (%)"; Expression = {$_.PercentProcessorTime}},   
        @{Name="Memory (MB)"; Expression = {[Math]::Round(($_.workingSetPrivate / 1mb),2)}}
    )
    Get-WmiObject -class Win32_PerfFormattedData_PerfProc_Process |
        Select-Object $properties |
        Format-Table -AutoSize
2
  • did you tried to use checkcpuperprocess key? (without [*]) – Toumash May 22 '20 at 8:24
  • Yeah, it's not working either. I think I'm missing something but I can't identify what exactly – Michal May 22 '20 at 8:34
3

Make sure that you have enabled UnsafeUserParameters in Zabbix Agent config file.

https://www.zabbix.com/documentation/current/manual/appendix/config/zabbix_agentd

1
  • Worked for me! Thanks bro – Toumash Jun 24 '20 at 19:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.