I read that squid was one of the easier proxy to configure but I have some issues.

The server is on aws ec2

I followed this tutorial https://www.tecmint.com/install-squid-in-ubuntu/

Changing http_port 3128 to http_port 3128 transparent


http_access deny all to http_access allow all

But I have

ERROR: NF getsockopt(ORIGINAL_DST) failed on local=xx.xx.xx.xx:3128 remote=xx.xx.xx.xx:62780 FD 10 flags=33: (92) Protocol not available
ERROR: NAT/TPROXY lookup failed to locate original IPs on local=xx.xx.xx.xx:3128 remote=xx.xx.xx.xx:62780 FD 10 flags=33

I also tried to add

acl localnet src XX.XX.XX.XX

where XX.XX.XX.XX is my ip

Or also

acl localnet src all

But I always have the same issue

I just want to sent request to an api having a static ip, do not konw if setting up squid is a good solution.

I already tried with nginx, it was working good but I made some update to my code and not working now

I am open to all solutions :)


Squid is enough complex to configure.

My recommendation is to use Netgate PfSense if it's getting provided by Amazon ec2. By having the Pfsense installed, you will be provided with a nice & simple web interface to manage and install/configure your squid proxy. for your type of required service, the web GUI is more than enough, but if need more customizains, you have a full SSH access to the OS itself to configure the Squid server configuration directly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.