3

as the title suggests I cannot get across the finish line installing arch on zfs. I get to the point where I try and install grub on my /boot after chrooting into my /mnt from the live cd. anyway here is my command and error:

# nvim /etc/grub.d/40_custom
set timeout=5
set default=0

menuentry "Arch Linux" {
   search -u UUID
   linux /vmlinuz-linux zfs=rpool/ROOT/default rw
   initrd /initramfs-linux.img
}

Then I try and make my grub via:

# ZPOOL_VDEV_NAME_PATH=1 grub-mkconfig -o /boot/grub/grub.cfg

And I get this error:

Generating grub configuration file ...
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/initramfs-linux.img
/usr/bin/grub-probe: error: unknown filesystem.
Found fallback initrd images(s) in /boot: initramfs-linux-fallback.img
done

As you can see I am getting an unknown filesystem error, however when I run:

# grub-probe /

I get

zfs

So I see zfs when I run grub-probe but get unknown filesystem when I run grub-mkconfig.

Not sure what information you need to help me track this down... been googling and hacking on this for 2 days now, I would really appreciate some help on this one.

1

I'm not sure about arch, but I think this:

zfs=rpool/ROOT/default

should be:

root=ZFS=rpool/ROOT/default

Are you sure the arch build of grub supports zfs? Did you make sure the ZFS pool was created without any of the feature flags that grub doesn't support?

On EL7 /boot on ZFS was easy enough, but on EL8, various questionable grub configuration changes made it impractical, so I gave up in that and just have a small mdraid partition for /boot on xfs. It's not perfect but it's livable with. You may have to do similar in arch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.