1

I have two workgroup hosts running Hyper-V 2016 and they replicate some of their VMs between themselves using certificate auth.

I have inherited this setup and can see that some of the VMs are happy replicating themselves but we have a few VMs that are not replicated and therefore a single point of failure.

When enabling replication on one of the VMs that has not been replicated I can not get past the "specify replica server" screen on the Extended replication wizard.

I enter the name of the target replica server, click next and then the "Verifying configuration..." dialogue flashes on and off until it's manually stopped. (I've left it over night, to find it doing the same thing in the morning)

It's like it's stuck in some sort of infinite loop.

I've trawled the internet and cannot find a solution to this. The only thing that came close was a similar post suggesting removing the replication server from the trusted-host list.

The trusted host list on both of my servers is set to allow any *.

Anyone got any thoughts?

0

I resolved the same issue adding in the first server the credentials for the replica server using cmdkey like this:

cmdkey.exe /add:REPLICASERVERHOSTNAME
/user:REPLICASERVERHOSTNAME\Administrator /pass:PASSWORD
| improve this answer | |
  • That's exactly what it was. This has been days of frustration. Thank you. – blondebier21 Jul 17 at 16:05
0

I found even more stupid way to get it resolved! It works for me

What I did was manipulating the host file in the primary server.

For instance if my replication server name is 'replicationserver' with IP 192.168.3.54

Normally you would be putting this in host file

replicationserver 192.168.3.54

instead, I modified it to replication-server 192.168.3.54

Then enable replication and put replica server name replicationserver and click next. You will see verifying configuration.... and of course, it will not be resolve.

Enable Replication then Enter Replica Server Name

However, it skipped to next part.

After put Replica Server Name

After done configuring replication and ready to replicate, change the host file back to

replicationserver 192.168.3.54

Then you should be able to start replication!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.