I'm on Windows 10 / Windows server 2012 R2.

I changed the user principal name for an account in active directory to a different domain. I was able to login into the account, everything seemed to be working until I tried using Windows Search.

The "Type here to search" on taskbar and File Explorer search no longer work. Clicking the search box doesn't display a flashing cursor showing your ready to type. Typing after clicking search box will not display the text I'm typing or search results.

I've tried running search index rebuild + troubleshooter without luck.

I reverted the UPN domain back to the original and search functionality is still broke.

If I login with a different username on the same PC the search works as expected.

Anyone shed some light on what's going on here?

UPDATE: Clicking on the search box causes an event error.

Unable to start a DCOM Server: Microsoft.Windows.Search_1.14.0.19041_neutral_neutral_cw5n1h2txyewy!CortanaUI as Unavailable/Unavailable. The error: "2147958016" Happened while starting this command: "C:\Windows\SystemApps\Microsoft.Windows.Search_cw5n1h2txyewy\SearchApp.exe" -ServerName:CortanaUI.AppX8z9r6jm96hw4bsbneegw0kyxx296wr9t.mca

UPDATE 2 I was able to restore search functionality by deleting the affected user profile and signing back into the domain. Still not sure what happened or why the profile became corrupted after changing the UPN.

To delete user profile go to:

System -> Advanced system settings -> User Profiles
  • Surely you mean "principal" name? – Law29 Jun 9 at 20:27
  • 1
    I surely do... doh! – payling Jun 9 at 20:31

For me reinstalling the Windows Search Component solved the same error. To do so open PowerShell as Administrator and execute:

Get-AppxPackage Microsoft.Windows.Search | foreach { Add-AppxPackage
-DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml" }
| improve this answer | |

I suffered from the exact same problem as described in the original post after Windows Update KB4557957 installed itself.

The fix was to Uninstall the update then reinstall the Windows Search component by running the following PowerShell command as "Admin".

Get-AppxPackage Microsoft.Windows.Search | foreach { Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml" }

Thanks to the previous contributors for guiding me out of this one.

| improve this answer | |

The error 2147958016 means that the application is currently updating (I can say that because I converted the error code to hex, then looked up the error code on this page: https://docs.microsoft.com/en-us/windows/win32/appxpkg/troubleshooting#common-error-codes)

Install all pending updates available in Microsoft Store and Windows Update, and restart the computer.

| improve this answer | |
  • There are no pending updates. I've also restarted the computer a number of times trying various fixes. – payling Jun 9 at 20:24
  • usually remove the cache from windows search and checl the permissions – djdomi Jul 7 at 20:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.