2

So I have two domains, both use the same htdigest settings and password, etc. The problem is that it doesn't use the same auth over on the other one. My two htdigest locations are: http://svn.kylehotchkiss.com and http://apps.kylehotchkiss.com/codex. Here is the config for my svn.kylehotchkiss.com domain:

 <Directory />
  DAV svn
  SVNParentPath /srv/svn.kylehotchkiss.com/repo
  SVNListParentPath On

  AuthType Digest
  AuthName "KHP Code Repository"
  AuthDigestDomain / http://svn.kylehotchkiss.com/ http://apps.kylehotchkiss.com/codex/
  AuthDigestProvider file
  AuthUserFile /srv/svn.kylehotchkiss.com/auth/passwd
  Require valid-user
 </Directory>

and my code for the apps.kylehotchkiss.com/codex/ is in a .htaccess file there and this is how it goes:

AuthType Digest
AuthName "KHP Code Repository"
AuthDigestDomain / http://apps.kylehotchkiss.com/codex/ http://svn.kylehotchkiss.com/
AuthDigestProvider file
AuthUserFile /srv/svn.kylehotchkiss.com/auth/passwd
Require valid-user

So what exactly am I missing with the AuthDigestDomain settings that doesn't allow the two to work together? Is the .htaccess file in the wrong spot?

1

If you are using a .htaccess file then you have to have

AllowOverride AuthConfig

in your main server configuration.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.