I have a Windows Server 2003 machine (I know, but it’s out of my control) with a bunch of network shares on it. I have a laptop that has just been rebuilt with Windows 10 2004. I’ve enabled CIFS/SMB1 in the Windows Features dialogue and I can browse to the network shares OK using the UNC in File Explorer and via the Run prompt.

However, as soon as I map one of these shares as a network drive File Explorer fails to connect. If I click on one of the drives it just seems to hang Explorer and eventually times out (if I don’t force restart Explorer before that). Prior to the rebuild the laptop connected to the mapped drives fine even after being upgraded to Windows 10 2004, as do other laptops.

What am I missing that allows other laptops to connect to these drives? Are there any other settings that I should be using to resolve this?

  • Did I get downvoted because the question isn’t clear or because it relates to Windows 2003?
    – Darren
    Jun 12, 2020 at 17:32

3 Answers 3


I wrestled with this one today. The main points were:

  1. Enable SMB1 support (run -> optionalfeatures -> SMB 1.0/CIFS File sharing support -> Client) and disable the Automatic removal feature.

  2. Re-enable two services: "Function discovery resource publication" and "Function discovery Provider Host"

  3. Create the following registry key:

    type REG_DWORD and value 1

My starting point was an embedded CNC machining tool that runs 2k server and Windows 10 2004, explorer in Windows would completely freeze after attempting to connect the server, according the user it used to work before.

I tip my hat at Samuli for pointing me to the 3rd step that finally solved the whole thing.

Edit: Be sure to add the registry value to every mapped drive in case you have more than one.


I have the same problem with Windows 10 2004.

Try to restart Workstation service. It takes about 5-10 mins for me. (But after reboot it doesnt work too.) so after the Workstation service restart delete your mapped drive with "net use drive /delete" and create a script which will connect your mapped drive, and put it into "startup" folder:

net use /persistent:no

net use yourdrive uncpath /persistent:no


I've had some success mapping the network shares using their IP address instead of using the server name. It only fails twice a month instead of every other day. It's not a fix but at least people can work for a few days without calling helpdesk.

If Windows lets you, you should rollback to 1909 or 1903 while you get rid of your Windows Server 2003 machines.

Of course, upgrading Windows Server 2003 to a version that's not end of life is the proper way to deal with this issue,

  • Thanks, I will give it a go. I’m not responsible for the presence or removal of the 2003 boxes.
    – Darren
    Sep 28, 2020 at 11:15
  • @Darren How did it go?
    – bort
    Oct 20, 2020 at 13:26
  • same problem unfortunately. Haven’t tried it since so no idea if it’s been fixed in a recent update.
    – Darren
    Oct 20, 2020 at 13:31

Not the answer you're looking for? Browse other questions tagged .