0

A real "Knacknuss"...

I have an Ubuntu Server, and setup Samba for Windows to connect. All is working fine but for that one particular Windows computer (Win 10 pro) that can not connect.

How can I get this one computer to also connect?

Ping is working.

For that one computer I keep getting the Windows Security Enter network credentials popup window. And it never logs on. I can't get passed that Enter network credential window. All other computers have no problem connecting.

Windows Security Enter network credentials

Things I tried:

I turned off the firewall.

Deleted Network Credentials.

Checked that the hosts file has nothing funny in it.

Checked Windows for corrupted system files.

I made sure that SMB 1.0/CIFS File Sharing Support in Windows Features is installed.

I also added a DWORD in Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\AllowInsecureGuestAuth of the value 1 to the registry, as suggested here.

Errors vary between the above, and occasionally this one

Windows cannot access check the spelling of the name.

1

I just found this answer, and it worked!

... my solution was to adjust the security policies on the Windows client.

Run > Secpol.msc

then I set Local Policies > Security Options > Network Security: LAN Manager authentication level to 'Send NTLMv2 response only. Refuse LM & NTLM' and the client connects just like before.

or

adding this in the share in /etc/samba/smb.conf will also fix it

ntlm auth = true
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.