0

This all started when I was trying to do a HTTPWebRequest to a Web Service. I was debugging my project and I received an error "The requested resource can only be accessed via SSL". So, I did some more trouble shooting and I found that my SSL Setting on server for the site was not checked for "Require SSL". So, I checked the "Require SSL" and the button Ignore Client Certificates. Now my HttpWebRequest returns a 403 Forbidden error, as well as the trying to access the site in the browser. What can to do further troubleshoot this issue?

6
  • I am pretty certain this is the case, I did not do this, but how can I check? – Paul T. Rykiel Jun 15 '20 at 18:04
  • yes, we definitely have this set up, also I went into Advanced settings and enabled "https". – Paul T. Rykiel Jun 15 '20 at 18:15
  • Are you definitely using HTTPS scheme in your URL? The Require SSL option only blocks you from using HTTP (non-TLS) - it doesn't enable TLS in any way. – garethTheRed Jun 15 '20 at 18:30
  • yes my URL Is "Https://intranet.somesite.com/ssc/webapi" – Paul T. Rykiel Jun 15 '20 at 18:36
  • Never use "Require SSL" but HTTP to HTTPS redirection. – Lex Li Jun 16 '20 at 3:05
0

Require SSL the option to choose when you want to enable two way mutual ssl authentication. Means the client needs to send it's certificate as well which will be authenticated by the server and then only the client will get access. In your case you wanted https to be mandatory whenever someone accesses your site. For that redirects can be created from http to https.

1
  • Thank you. I appreciate your response. – Paul T. Rykiel Jun 19 '20 at 18:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.