0

When I run yum update, after dependency resolution I get the following error:

--> Finished Dependency Resolution
Error: Package: php71w-pecl-imagick-3.4.3-1.w7.x86_64 (@webtatic)
           Requires: libMagickWand.so.5()(64bit)
           Removing: ImageMagick-6.7.8.9-18.el7.x86_64 (@base)
               libMagickWand.so.5()(64bit)
           Updated By: ImageMagick-6.9.10.68-3.el7.x86_64 (base)
               Not found
Error: Package: php71w-pecl-imagick-3.4.3-1.w7.x86_64 (@webtatic)
           Requires: libMagickCore.so.5()(64bit)
           Removing: ImageMagick-6.7.8.9-18.el7.x86_64 (@base)
               libMagickCore.so.5()(64bit)
           Updated By: ImageMagick-6.9.10.68-3.el7.x86_64 (base)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

My understanding is that ImageMagick wants to update to 6.9.10.68-3, but this doesn't provide libMagickCore.so.5 or libMagickWand.so.5, so it's blocking the upgrade because that would stop php71w-peclimagick from working?

Is it actually impossible here to upgrade ImageMagick, or would I need to keep it at an earlier version? What's the best way forward?

Note: php71w* come from webtatic.

Update

One possible fix is the following:

yum install yum-plugin-versionlock
yum versionlock ImageMagick

After this the current ImageMagick version is locked and the rest of the updates work.

Is this a suitable fix or can anyone suggest anything better?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.