2

I set up Amazon Linux AMI EC2 instance via ECS (elastic container service).

It seems like by default it doesn't have that many packages installed.

When I'm trying to install certbot using the command:

sudo yum install certbot

I get errors like:

Error: Package: python2-six-1.9.0-0.el7.noarch (epel)
           Requires: python-six >= 1.9.0
           Available: python26-six-1.8.0-1.23.amzn1.noarch (amzn-main)
               python-six = 1.8.0-1.23.amzn1
Error: Package: python2-certbot-1.4.0-1.el7.noarch (epel)
           Requires: python2-cryptography >= 1.2.3
Error: Package: python2-acme-1.4.0-2.el7.noarch (epel)
           Requires: pyOpenSSL >= 0.13.1
           Available: python26-pyOpenSSL-0.10-2.8.amzn1.x86_64 (amzn-main)
               pyOpenSSL = 0.10-2.8.amzn1
Error: Package: certbot-1.4.0-1.el7.noarch (epel)
           Requires: systemd
Error: Package: python2-six-1.9.0-0.el7.noarch (epel)
           Requires: python-six >= 1.9.0
           Installing: python26-six-1.8.0-1.23.amzn1.noarch (amzn-main)
               python-six = 1.8.0-1.23.amzn1

And it's not installed.

What can I do?

1

You can't use the EPEL repository with Amazon Linux 2, because it is not compatible with this Linux distribution. Packages from EPEL are not intended for Amazon Linux 2, and even if you somehow managed to install one, it probably would not work.

You will need to obtain certbot from another source, or use another Linux distribution.

3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.