0

I'm trying to upgrade to Postfix 3 on Centos, using these instructions:

https://www.ryadel.com/en/postfix-3-install-setup-linux-centos-for-sending-mail-smtp-smtps-starttls/

However, I'm getting the following dependency errors:

$ sudo yum install postfix3
Loaded plugins: fastestmirror, priorities, replace, security
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: mirror.strencom.net
 * extras: mirror.strencom.net
 * remi-php56: mirror.netweaver.uk
 * remi-php72: mirror.netweaver.uk
 * remi-safe: mirror.netweaver.uk
 * updates: ftp.heanet.ie
gf                                                                                                                                                | 2.9 kB     00:00     
gf/primary_db                                                                                                                                     |  44 kB     00:00     
gf-plus                                                                                                                                           | 2.9 kB     00:00     
gf-plus/primary_db                                                                                                                                | 104 kB     00:00     
156 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package postfix3.x86_64 2:3.5.2-1.gf.el7 will be installed
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: 2:postfix3-3.5.2-1.gf.el7.x86_64
--> Processing Dependency: libsasl2.so.3()(64bit) for package: 2:postfix3-3.5.2-1.gf.el7.x86_64
--> Processing Dependency: libicuuc.so.50()(64bit) for package: 2:postfix3-3.5.2-1.gf.el7.x86_64
--> Processing Dependency: libicui18n.so.50()(64bit) for package: 2:postfix3-3.5.2-1.gf.el7.x86_64
--> Processing Dependency: libicudata.so.50()(64bit) for package: 2:postfix3-3.5.2-1.gf.el7.x86_64
--> Processing Dependency: libdb-5.3.so()(64bit) for package: 2:postfix3-3.5.2-1.gf.el7.x86_64
--> Running transaction check
---> Package libicu-last.x86_64 0:50.1.2-17.el6.remi will be installed
---> Package postfix3.x86_64 2:3.5.2-1.gf.el7 will be installed
--> Processing Dependency: libcrypto.so.10(OPENSSL_1.0.2)(64bit) for package: 2:postfix3-3.5.2-1.gf.el7.x86_64
--> Processing Dependency: libsasl2.so.3()(64bit) for package: 2:postfix3-3.5.2-1.gf.el7.x86_64
--> Processing Dependency: libdb-5.3.so()(64bit) for package: 2:postfix3-3.5.2-1.gf.el7.x86_64
--> Finished Dependency Resolution
Error: Package: 2:postfix3-3.5.2-1.gf.el7.x86_64 (gf-plus)
           Requires: libsasl2.so.3()(64bit)
Error: Package: 2:postfix3-3.5.2-1.gf.el7.x86_64 (gf-plus)
           Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit)
Error: Package: 2:postfix3-3.5.2-1.gf.el7.x86_64 (gf-plus)
           Requires: libdb-5.3.so()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Any advice on correcting these dependencies would be greatly appreciated.

Kind regards,

James

  • CentOS 6? Why on earth are you trying to use such an old distro? Just install CentOS 8; it already has Postfix 3. – Michael Hampton Jun 21 at 20:36
  • Thanks Michael. Unfortunately, there are reasons outside my control that this server has to stay on Centos 6. I expect the content will be migrated to a new Centos 8 server later in the year and this one decommissioned. However, it would be useful to update Postfix as a stop-gap. – James Shields Jun 21 at 22:17
1

You are trying to install el7 packages, designed for CentOS 7 with el6 packages, designed for CentOS 6.

You need to properly configure the repository you are using, and probably update to CentOS 7 or 8 as 6 is close to its end of life, in a few months.

| improve this answer | |
  • This solved my problem. I changed my repository to el6 and downloaded the el6 key, and I was able to install Postfix 3 from that. However, I recognise that I need to replace this server with something more modern, and am looking to commission a Centos 8 server to replace it in the next few months. – James Shields Jul 5 at 21:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.