2

I'm trying to exclude *.i686 packages from installing when I try to install the x86_64 version of libcrypto.so.10.

If I put any of the following (one at a time) into my /etc/yum.conf under [main]:

multilib_policy=best
exactarch=1
exclude=*.i386 *.i686
exclude=*.i?86

And I try to install the package it says that it isn't there:

sudo yum install libcrypto.so.10
Loaded plugins: fastestmirror, rhnplugin, tsflags, versionlock
This system is receiving updates from RHN Classic or Red Hat Satellite.
Loading mirror speeds from cached hostfile
No package libcrypto.so.10 available.
Error: Nothing to do

However if I remove any of those settings it tries to install both i686 and the x86_64 version of libcrypto.so.10. I am using Centos version: CentOS Linux release 7.7.1908 (Core)

How can I exclude *.i686 packages in the /etc/yum.conf file?

2

You couldn't install libcrypto.so.10 by mentioned command. First you should locate which package contains this library by executing yum provides libcrypto.so.10 and then install package.

Or you could directly install required package.

| improve this answer | |
  • Thanks. But that doesn't address the question of how I exclude *.i686 packages from being installed using /etc/yum.conf. I want to be able to do this for other packages as well, not just for libcrypto.so.10. – user99201 Jun 29 at 0:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.