2

I have a clean install of Ubuntu 20.04 and have setup screen sharing. It gives me an URL to use to access the desktop, something like vnc://my-computer.local When I type this in a web browser on the MacBook, the browser offers to open it up in Screen Sharing, but if I select that, I get the following error message:

The software on the remote computer appears to be incompatible with this version of Screen Sharing.

I tried installing TigerVNC on the Mac, but without success - nothing installed, no error messages, nothing.

Which VNC client should I try next? I need one that is compatible with Mac OS Catalina, and with the Ubuntu 20.04 VNC implementation?

8

I also had this problem earlier. [My original comment was just a "I have this too" post and was deleted. This comment does have a solution:]

It looks like the two systems cannot negotiate an appropriate encryption level to use between them. It seems like it has happened in the past with earlier versions of Ubuntu and Mac OS X. the solution at the time was switching off encryption for the screen sharing and it has worked for me with Ubuntu 20.04.

eg on the ubuntu 20.04 box from a terminal session...

gsettings set org.gnome.Vino require-encryption false

I was then able to use Mac OS X Finder to Go to (in my case) vnc://192.168.1.170 which failed before.

Also Royal TSX worked as a screen sharing client on MacOSX where it did not before.

Of course you may not wish to run screen sharing without encryption. In particular it might mean that the password used would be transported in plain text across the network. However, if this is an unacceptable risk for you then at least trying it out you will have identified the problem.

2
  • 1
    I could not get this to work. Disabling encryption did not fix the version conflict :(
    – Wouter
    Aug 21 '20 at 8:44
  • You can use this solution over an SSH tunnel to get encryption protection. For example, ssh to your Ubuntu server like this: ssh -L 5900:127.0.0.1:5900 ubuntu-server-name and then you can connect from your Mac to vnc://127.0.0.1, which will be forwarded over the SSH connection. Adjust the apparent port number on the Mac as needed, if there are multiple VNC servers involved.
    – twm
    Mar 19 at 16:14
2

Had the same problem and Alex's suggestion didn't fix it but help me figure out what was happening.

Update 12/9/20

I had to install X11VNC before the above would work on the latest box I built:

  • sudo apt-get update
  • sudo apt-get install x11vnc net-tools

THEN follow the steps below

First: Setup screen sharing via Settings. This is primarily to set the password in the keyring.

Second: Install dconf-editor and change multiple settings. (see below)

Third: Verify by connecting from the Mac.

Install & run dconf-editor sudo apt-get install dconf-editor

sudo dconf-editor

Navigate to org -> gnome -> desktop -> remote-access

Verify or change settings as follows:

  • authentication-methods: ['vnc'] (click twice to edit, was set to ['none'])
  • prompt-enabled: false (slider to off, was set to true/on)
  • require-encryption: false (slider to off, was set to true/on)
1

I found that using the gsettings set org.gnome.Vino require-encryption false command did not seem to remove the encryption setting for vino. However, installing the dconf editor from Ubuntu Software and using it to change the setting to false (similar to Ramsa's suggestion re: x11vnc above) did work!

After that, I was able to connect from a Mac laptop (Mojave) without getting the appears to be incompatible error. I found a blog that suggested this approach here.

0

I had a similar problem with an older version of Fusion. Whilst this is not on the face of it a similar issue, I suspect it might be to do with the new privacy settings on screen recording.

On your mac, go to Settings | Software & Security | Privacy tab. Scroll down on the list on the left of the screen until you get to Screen Recording and ensure the app that you want to use is allowed in the Screen Recording detail on the right, should just be a tick box.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.