0

I am trying to configure a jail in freenas inside virtualbox. The problem I am having is that I cannot access the internet inside my jail.

My jail is configured without NAT. Only with VNET without DHCP.

My jail's network settings are:

root@reverse-proxy:~ # ifconfig
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        options=680003<RXCSUM,TXCSUM,LINKSTATE,RXCSUM_IPV6,TXCSUM_IPV6>
        inet6 ::1 prefixlen 128
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
        inet 127.0.0.1 netmask 0xff000000
        nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
        groups: lo
epair0b: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=8<VLAN_MTU>
        ether 0a:00:27:b5:7c:2b
        hwaddr 02:4d:d5:00:05:0b
        inet 192.168.0.105 netmask 0xffffff00 broadcast 192.168.0.255
        inet 0.0.0.0 netmask 0xff000000 broadcast 255.255.255.255
        inet6 fe80::800:27ff:feb5:7c2b%epair0b prefixlen 64 scopeid 0x2
        nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
        media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
        status: active
        groups: epair

My FreeNAS network configuration is:

root@freenas[~]# ifconfig
le0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
        description: 192.168.0.103
        options=8<VLAN_MTU>
        ether 08:00:27:53:ea:5d
        hwaddr 08:00:27:53:ea:5d
        inet 192.168.0.103 netmask 0xffffff00 broadcast 192.168.0.255
        nd6 options=9<PERFORMNUD,IFDISABLED>
        media: Ethernet autoselect
        status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        options=680003<RXCSUM,TXCSUM,LINKSTATE,RXCSUM_IPV6,TXCSUM_IPV6>
        inet6 ::1 prefixlen 128
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2
        inet 127.0.0.1 netmask 0xff000000
        nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
        groups: lo
bridge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        ether 02:5a:f8:c5:85:00
        nd6 options=1<PERFORMNUD>
        groups: bridge
        id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
        maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200
        root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
        member: vnet0.1 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
                ifmaxaddr 0 port 4 priority 128 path cost 2000
        member: le0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
                ifmaxaddr 0 port 1 priority 128 path cost 2000000
vnet0.1: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500
        description: associated with jail: r-proxy as nic: epair0b
        options=8<VLAN_MTU>
        ether 0a:00:27:b5:7c:2a
        hwaddr 02:35:d0:00:04:0a
        inet6 fe80::800:27ff:feb5:7c2a%vnet0.1 prefixlen 64 scopeid 0x4
        nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
        media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)
        status: active
        groups: epair

Executing the netstat -nr command, I have the following table:

root@reverse-proxy:~ # netstat -nr
Routing tables

Internet:
Destination        Gateway        Flags     Netif Expire
0.0.0.0/8          link#2         U         epair0b
default            192.168.0.1    UGS       epair0b
127.0.0.1          link#1         UH        lo0
192.168.0.0/24     link#2         U         epair0b
192.168.0.105      link#2         UHS       lo0

Internet6:
Destination                        Gateway                       Flags     Netif         Expire
::/96                              ::1                           UGRS        lo0
::1                                link#1                        UH          lo0
::ffff:0.0.0.0/96                  ::1                           UGRS        lo0
fe80::/10                          ::1                           UGRS        lo0
fe80::%lo0/64                      link#1                        U           lo0
fe80::1%lo0                        link#1                        UHS         lo0
fe80::%epair0b/64                  link#2                        U       epair0b
fe80::800:27ff:feb5:7c2b% epair0b  link#2                        UHS         lo0
ff02::/16                          ::1                           UGRS        lo0
root@reverse-proxy:~ #

In the virtualbox network configuration I have configured a bridge and the promiscuous mode> allow everything.

What could be the problem?.

Regards

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.