1

I have an issue with a couple of users in the database.

I noticed this when tried to add a new user, the CREATE USER, GRANT and FLUSH PRIVILEGES get executed correctly and SHOW GRANTS FOR 'reporte' shows the correct information for the new user, but i'm unable to use it for login to the database.

I went to look for the user in the mysql.user table, and it gets inserted BUT i also have these blank users (with no password)

MariaDB [(none)]> select Host, User, Password from mysql.user;
+-----------------------+-------------+-------------------------------------------+
| Host                  | User        | Password                                  |
+-----------------------+-------------+-------------------------------------------+
| localhost             | root        |                                           |
| localhost.localdomain | root        |                                           |
| 127.0.0.1             | root        |                                           |
| ::1                   | root        |                                           |
| localhost             |             |                                           |
| localhost.localdomain |             |                                           |
| localhost             | freepbxuser | *1F0450426F77A1                           |
| %                     | reportes    | *2BA18D13                                 |
+-----------------------+-------------+-------------------------------------------+
8 rows in set (0.00 sec)

I tried to DROP them with DROP USER '' but of course it shows an error.

This is FreePBX system and regardless of the bug report on their part I want to know what happens if I just do

DELETE FROM mysqluser where User = '' and Host = 'localhost';

Is the same as DROP USER? I haven't been able to find the answer in the documentation. The version is 5.5.60-MariaDB

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.