0

I am attempting to go through the Terraform install from their website at https://learn.hashicorp.com/terraform/azure/install When I get to the step that says to run terraform apply I get the following error:

Error: Error initializing Docker client: protocol not available

  on <empty> line 0:
  (source code not available)

I am not sure what to do, any suggestions? I am running this on a Windows 10 Pro machine.

1 Answer 1

1

Ok, so I found an answer that works. I am not sure what it means, but it did solve my problem. According to an issue posted on github at https://github.com/terraform-providers/terraform-provider-docker/issues/180 I added the following to my main.tf file:

provider "docker" {
  version = "~> 2.7"
  host    = "npipe:////.//pipe//docker_engine"
}

This allowed me to run the command terraform apply successfully. If anyone can explain the details of this, I'd appreciate it. I really don't fully grasp the host setting. But, it works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .