0

I'm trying to set the MTU value for my network interface in FreeNAS-11.3-U3.2 to 9000.

However, when I select the interface to EDIT in the WebUI, enter 9000 for the MTU field, then click "APPLY", I get the following error.

VALLIDATION ERRORS:
[EINVAL] interface_update.aliases.0: The network 192.168.1.0/24 is already in use by another interface.

NOTE: I previously was unable to configure the interface via the WEBUI when setting the IP (resulting in the same error), and successfully set the interface via the freenas console.

Is there a setting I need to change in order to enable network configuration (specifically MTU) for network interfaces in the WEBUI?

Or, alternatively, how can I set the MTU value?


UPDATE: looks like I was able to set mtu=9000 via the shell, but isn't persistent after reboot.

# update interface mtu
ifconfig em0 10.20.110.2 mtu 9000

# NAS to {OTHER MACHINE WITH 10GbE}
# ping -D -s 8972 {OTHER MACHINE WITH 10GbE}
PING {OTHER MACHINE WITH 10GbE} ({OTHER MACHINE WITH 10GbE}): 8972 data bytes
8980 bytes from {OTHER MACHINE WITH 10GbE}: icmp_seq=0 ttl=64 time=0.538 ms
8980 bytes from {OTHER MACHINE WITH 10GbE}: icmp_seq=1 ttl=64 time=1.221 ms
8980 bytes from {OTHER MACHINE WITH 10GbE}: icmp_seq=2 ttl=64 time=0.557 ms
8980 bytes from {OTHER MACHINE WITH 10GbE}: icmp_seq=3 ttl=64 time=1.310 ms

6
  • Are you trying to change the MTU on the interface you’re connected to? – Vinícius Ferrão Jul 6 '20 at 4:16
  • I've tried both, from the interface I'm connected to and from an interface that's different, both result in the same error. – monkut Jul 6 '20 at 4:33
  • What other interface was configured with that network? – Michael Hampton Jul 6 '20 at 4:35
  • I have three interfaces, 2 connected at the moment, set to ips 192.168.1.(20|21|22) with same netmask. As mentioned I wasn't initially able to configure these IPs through the WebUI (with the same error), and ended up setting them directly through the console. – monkut Jul 6 '20 at 4:57
  • Do you have any bridge or LACP aggregation configured? – Mircea Vutcovici Jul 6 '20 at 5:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.