0

So I have gone through about a dozen other threads as well as read the http://svnbook.red-bean.com/en/1.8/svn.serverconfig.pathbasedauthz.html I feel like I have tried everything, and either there is anonymous read to the repository url, or I loose read and write access with authenticated users. I must be doing something stupid.

dav_svn.authz file :

    [MyRepository:/]
    $anonymous =
    name = rw
    * = r
    
    [/]
    * = r
    $anonymous =
    $authenticated = rw
    name = rw

my site file:

 <Location /repourl>
            DAV svn
            SVNParentPath /var/lib/svn
            AuthType Basic
            AuthName "Subversion Repository"
            AuthUserFile /etc/apache2/dav_svn.passwd
            <IfModule mod_authz_svn.c>
                    AuthzSVNAccessFile /etc/apache2/dav_svn.authz
            </IfModule>
            <LimitExcept GET PROPFIND OPTIONS REPORT>
                    Require valid-user
            </LimitExcept>
    </Location>

Overall without * = r my authenticated user cannot read or write, but with * = r there is anonymous access, i.e i can navigate to the url and see it. First question, even when * = r comes first, anonnymous users can not access the root '/' to the repository, but can access "MyRepository" even though they have the same settings? Also why would anonymous get access when "$anonymous =" and "Require valid-user". Basically I just need no anonymous access and RW access for the user. I have tried about 100 different combinations of things seeing if any of them would work, I just didn't want to post all the different combinations I have tried. any help is greatly appreciated.

1 Answer 1

0

I figured it out!!!!!

<LimitExcept GET PROPFIND OPTIONS REPORT>

Should be

<LimitExcept PROPFIND>

propfind will prompt the user for the user name and password instead of just displaying access.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.