0

I'm using samba on Fedora Server Edition. But I can't figure out why any windows can not see it. It can connect (directly, using ip address). It basically works, but I can't see them on either linux (using nautilus) nor windows explorer.

Basics:

  • OS: Fedora Server Edition 32
  • hostname: bienenstock.local
  • samba: 4.12.5-0.fc32.x64_64
  • firewall is running (samba is allowed - I'm able to connect directly)
  • SELinux is enforcing (reading/writing on shares works fine)
$ systemctl status nmb smb
● nmb.service - Samba NMB Daemon
     Loaded: loaded (/usr/lib/systemd/system/nmb.service; enabled; vendor preset: disabled)
     Active: active (running) since Mon 2020-07-13 11:31:32 CEST; 29min ago
       Docs: man:nmbd(8)
             man:samba(7)
             man:smb.conf(5)
   Main PID: 2577 (nmbd)
     Status: "nmbd: ready to serve connections..."
      Tasks: 2 (limit: 4516)
     Memory: 4.0M
        CPU: 568ms
     CGroup: /system.slice/nmb.service
             ├─2577 /usr/sbin/nmbd --foreground --no-process-group
             └─2586 /usr/sbin/nmbd --foreground --no-process-group

Jul 13 11:47:04 bienenstock.local nmbd[2577]: [2020/07/13 11:47:04.016820,  0] ../../source3/nmbd/nmbd_browsesync.c:354(find_domain_master_name_query_fail)
Jul 13 11:47:04 bienenstock.local nmbd[2577]:   find_domain_master_name_query_fail:
Jul 13 11:47:04 bienenstock.local nmbd[2577]:   Unable to find the Domain Master Browser name WORKGROUP<1b> for the workgroup WORKGROUP.
Jul 13 11:47:04 bienenstock.local nmbd[2577]:   Unable to sync browse lists in this workgroup.

● smb.service - Samba SMB Daemon
     Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled; vendor preset: disabled)
     Active: active (running) since Mon 2020-07-13 11:31:33 CEST; 29min ago
       Docs: man:smbd(8)
             man:samba(7)
             man:smb.conf(5)
   Main PID: 2587 (smbd)
     Status: "smbd: ready to serve connections..."
      Tasks: 5 (limit: 4516)
     Memory: 9.2M
        CPU: 409ms
     CGroup: /system.slice/smb.service
             ├─2587 /usr/sbin/smbd --foreground --no-process-group
             ├─2598 /usr/sbin/smbd --foreground --no-process-group
             ├─2600 /usr/sbin/smbd --foreground --no-process-group
             ├─2602 /usr/sbin/smbd --foreground --no-process-group
             └─2669 /usr/sbin/smbd --foreground --no-process-group

Jul 13 11:31:32 bienenstock.local systemd[1]: Starting Samba SMB Daemon...
Jul 13 11:31:33 bienenstock.local systemd[1]: Started Samba SMB Daemon.
Jul 13 11:31:33 bienenstock.local smbd[2587]: [2020/07/13 11:31:33.151454,  0] ../../lib/util/become_daemon.c:135(daemon_ready)
Jul 13 11:31:33 bienenstock.local smbd[2587]:   daemon_ready: daemon 'smbd' finished starting up and ready to serve connections
testparm -s
Load smb config files from /etc/samba/smb.conf
Loaded services file OK.
Server role: ROLE_STANDALONE

# Global parameters
[global]
    add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
    domain master = No
    load printers = No
    logging = systemd
    logon drive = P:
    logon home = \\%L\%U\.9xprofile
    logon path = \\%L\profiles\.msprofile
    map to guest = Bad User
    name resolve order = bcast host
    printcap name = /dev/null
    server min protocol = SMB2
    usershare owner only = No
    wins support = Yes
    idmap config * : backend = tdb
    create mask = 0774
    directory mask = 0774
    hosts allow = localhost 192.168.25.
    include = /etc/samba/dhcp.conf
    invalid users = bin daemon ftp games lp mail man messagebus news ntp postfix root sshd statd usbmux uucp wwwrun avahi plex
    printing = bsd
    valid users = meh bine

[homenet]
    comment = Homenet
    path = /srv/homenet
    write list = meh bine

## and some others, but for sake of length of this writing I reduced the length

As you can see, both daemons are up and running (thou I do not understand why a "domain master name query" fails ... - might be relevant?).

Sadly looking up the internet only reveals problems related to samba, SELinux, etc. But this works, the only thing that does not is announcing it on windows explorer or nautilus. What am I missing?

Thank you in advance!

1

You have SMBv1 turned off (as it should be, it is very insecure) and SMBv1 is required for Network Browsing. Try installing this: https://github.com/christgau/wsdd It will allow your Windows clients to see your Samba machine using Network Discovery.

You might want to read 'man smb.conf', you have quite a few lines you don't need and don't have a line you do need ;-)

| improve this answer | |
  • Works like a charm! Thank you very much! Out of curiosity: which lines could be removed? – Michael Hirschler Jul 13 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.