1
bash-4.2# yum install openscap-containers
Resolving Dependencies
--> Running transaction check
---> Package openscap-containers.noarch 0:1.3.3-1.el7 will be installed
--> Processing Dependency: python(abi) = 3.6 for package: openscap-containers-1.3.3-1.el7.noarch
--> Processing Dependency: /usr/bin/python3 for package: openscap-containers-1.3.3-1.el7.noarch
--> Processing Dependency: /usr/bin/python3 for package: openscap-containers-1.3.3-1.el7.noarch
--> Finished Dependency Resolution
Error: Package: openscap-containers-1.3.3-1.el7.noarch (copr:copr.fedorainfracloud.org:openscapmaint:openscap-latest)
           Requires: python(abi) = 3.6
           Installed: python-2.7.5-88.el7.x86_64 (installed)
               python(abi) = 2.7
               python(abi) = 2.7
           Installed: python34-3.4.10-4.el7.x86_64 (@epel)
               python(abi) = 3.4
Error: Package: openscap-containers-1.3.3-1.el7.noarch (copr:copr.fedorainfracloud.org:openscapmaint:openscap-latest)
           Requires: /usr/bin/python3
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Even when I install python3 and am able to use it at /usr/bin/python3 it says I do not meet the requirements.

bash-4.2# yum install rh-python36
bash-4.2# ln -s /opt/rh/rh-python36/root/usr/bin/python /usr/bin/python3
2

Capability python(abi) = 3.6 and file /usr/bin/python3 are provided by python3 package in the base repository (reference).

You should run yum install openscap-containers while the base repository is enabled.

Since yum didn't pick it up as dependency, you have a problem that the base repository was disabled or its repo definition is missing.

In the latter case, yum reinstall centos-release.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.