0

currently I'm working on my veary own mailserver but I can't log in to the account I made. For now my client (Mozlla Thunderbird) detects the server config (STARTTLS, Port, ...) but it is "Unable to log in at server. Probbly wrong configuration, username or passsword".

I know that I added username and password correctly so there must something else be wrong.

I run Debian 10 x64 on a fresh installation.
Installed are: postfix, postfix-pcre, dovecot-core, dovecot-imapd and dovecot-pop3d.

Here are my configurations:
Postfix main.cf: https://pastebin.com/S17jWDQd
Postfix master.cf: https://pastebin.com/W0nynZG6
dovecot.conf: https://pastebin.com/tMD90Znn

This is what my server logs (mail.info, mail.warn) tell me:

root@bgrsld-mail0:~# tail /var/log/mail.info
Jul 17 18:22:08 bgrsld-mail0 postfix/submission/smtpd[8472]: improper command pipelining after EHLO from unknown[192.168.2.110]: QUIT\r\n
Jul 17 18:22:08 bgrsld-mail0 postfix/submission/smtpd[8465]: disconnect from unknown[192.168.2.110] ehlo=1 quit=1 commands=2
Jul 17 18:22:08 bgrsld-mail0 postfix/submission/smtpd[8472]: disconnect from unknown[192.168.2.110] ehlo=1 quit=1 commands=2
Jul 17 18:24:59 bgrsld-mail0 postfix/submission/smtpd[8485]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Jul 17 18:24:59 bgrsld-mail0 postfix/submission/smtpd[8485]: connect from unknown[192.168.2.110]
Jul 17 18:24:59 bgrsld-mail0 postfix/submission/smtpd[8485]: improper command pipelining after EHLO from unknown[192.168.2.110]: QUIT\r\n
Jul 17 18:24:59 bgrsld-mail0 postfix/submission/smtpd[8485]: disconnect from unknown[192.168.2.110] ehlo=1 quit=1 commands=2
Jul 17 18:28:19 bgrsld-mail0 postfix/anvil[8473]: statistics: max connection rate 2/60s for (submission:192.168.2.110) at Jul 17 18:22:08
Jul 17 18:28:19 bgrsld-mail0 postfix/anvil[8473]: statistics: max connection count 2 for (submission:192.168.2.110) at Jul 17 18:22:08
Jul 17 18:28:19 bgrsld-mail0 postfix/anvil[8473]: statistics: max cache size 1 at Jul 17 18:22:08
root@bgrsld-mail0:~# tail /var/log/mail.warn
Jul 17 18:21:50 bgrsld-mail0 postfix/postfix-script[8290]: warning: symlink leaves directory: /etc/postfix/./makedefs.out
Jul 17 18:22:08 bgrsld-mail0 postfix/submission/smtpd[8465]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Jul 17 18:22:08 bgrsld-mail0 postfix/submission/smtpd[8472]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Jul 17 18:24:59 bgrsld-mail0 postfix/submission/smtpd[8485]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled

(I removed any information from older issues that are already solved, hats why mail.warn miss a few lines and there is no mail.err)

Here is my only line from dovecot's userpass file (/maildata/userpass):

nils@intern.xxx.xxx:{CRYPT}$2y$05$kkxElxFGsLSyTJwbEaPZzO/QA33vGY3oGyHcgEZa9rpklgBTKQw9O

My postfix vhosts file (/maildir/vhosts)

intern.xxx.xxx

My postfix vmaps file (/maildir/vmaps)

nils@intern.xxx.xxx intern.xxx.xxx/nils/

I've also created the hased database with postmap /maildata/vmaps

I haven't worked with postfiy or dovecot yet so there are many things I don't know. because of this a lot of my configurations is copied from an iRedMail installation. I know that taking these configs may cause some problems but I don't know where to change them or whatever else is wrong or missing.

Thank you for any help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.