1

When compiling from source using:

# ./configure --prefix=/opt/znapzend-0.20.0
# make 
# make install

I get this error: ! Couldn't find module or a distribution Carton

I can compile version 0.19.1 from source without any issues. I am using 0.19.1 for a while now and I'm very happy with znapzend! Thank you for all your work. When I wanted to upgrade to 0.20.0 I ran into this problem.

I am using Ubuntu 20.04. I tried to install Carton like so:

# apt install carton
# carton -v
carton v1.0.34

But after installing carton I still get the same error when compiling.

The README contains directions to compile version 0.19.2, but doesn't contain directions for version 0.20.0 that is using carton for better dependency tracking.

Could you please help me with directions to setup Carton, so I can compile znapzend 0.20.0?

0
0

I found the problem. Carton is a Perl module dependency manager, that uses CPAN to install Perl modules. It wasn't enough to install Carton. CPAN is installed by default in Ubuntu, but it wasn't configured yet on my system.

I configured CPAN like this:

# sudo cpan
Loading internal logger. Log::Log4perl recommended for better logging

CPAN.pm requires configuration, but most of it can be done automatically.
If you answer 'no' below, you will enter an interactive dialog for each
configuration option instead.

Would you like to configure as much as possible automatically? [yes] 

Autoconfiguration complete.

commit: wrote '/root/.cpan/CPAN/MyConfig.pm'

You can re-run configuration any time with 'o conf init' in the CPAN shell
Terminal does not support AddHistory.

and let it auto configure. After this, I could compile znapzend 0.20.0 without any problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.