0

I have access to two servers:

  • A runs Ubuntu Server and I connect to it via SSH
  • B runs Windows Server 10

A should be able to connect to B:1433 to the MySQL Server.

Both A and B are on the same network.

I have tried to do:

mycli --verbose -u USER -h IP_OF_SERVER_B -P 1433 -p '...'

This times out.

However, nmap shows the 1433 port as open and telnet can connect to it.

$ sudo nmap IP_OF_SERVER_B
[sudo] password for ...: 

Starting Nmap 7.60 ( https://nmap.org ) at 2020-07-23 04:45 UTC
Nmap scan report for IP_OF_SERVER_B
Host is up (0.0014s latency).
Not shown: 999 filtered ports
PORT     STATE SERVICE
1433/tcp open  ms-sql-s

And:

$ telnet IP_OF_SERVER_B 1433
Trying IP_OF_SERVER_B...
Connected to 10.10.1.7.
Escape character is '^]'.

How can I connect to the MySQL Server? I already enabled remote access on the MySQL Server side.

  • 1433 is the default port of Microsoft SQL Server. You can connect via link – Burak Talha Bolat Jul 23 at 7:26
3

Your server is running MS SQL, and you are trying to connect to it using MySQL client.

MySQL and MS SQL are different products, and you cannot use tools designed for MySQL to access MS SQL server.

You need to use MS SQL client to access your MS SQL server.

| improve this answer | |
  • Thanks for this. I followed the instructions and installed sqlcmd. But now the error I get is SSPI Provider: No Kerberos credentials available and Cannot generate SSPI context.. I tried sqlcmd -S IP_OF_SERVER_B. – Ionică Bizău Jul 23 at 7:47
  • You need to check how your server's authentication is set up and adjust accordingly. – Tero Kilkanen Jul 23 at 13:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.